WebDav sync problem

I've been syncing with a webdav account on 4shared for several months without any problems ... until yesterday morning, when syncing stopped functioning. The verify server test in sync settings returns this message:

"Your WebDAV server must be configured to serve files without extensions and files with .prop extensions in order to work with Zotero."

Error ID: 1062640371

Any suggestions much appreciated.

  • Correction: In fact, attachments are syncing. But I continue to nonetheless to get a sync error exclamation mark and the message: "A WebDAV file sync error occurred. Please try syncing again."

  • Restart Firefox, reproduce the sync error, and provide another Report ID.
  • Here you go:

  • edited April 29, 2012
    This is immediately after a restart? There are a whole lot of errors in there from other extensions and websites, and (likely because of that) no Zotero ones. How about a Debug ID for the sync attempt instead?
  • edited April 29, 2012
    Sorry, I also restored the previous session.

    Debug ID is below.

    But here is the error report after both shutting down the computer (Mac OS 10.6) and restarting it and Firefox 11:


    Yes, there seems to be lot of stuff in the error list -- to do with Chrome, which I don't even use.

    But there is also this, repeated three times, which seems to involve Zotero and the webdav server:

    [JavaScript Error: "no element found" {file: "http://********:********@webdav.4shared.com/zotero/" line: 1}]

    The Debug ID is D951515704.

  • (chrome is a protocol used in Firefox, entirely unrelated to the browser of the same name)
  • (3)(+0000155): HTTP GET http://[...]@webdav.4shared.com/zotero/lastsync

    (3)(+0001326): <

    (3)(+0000000): 500

    (1)(+0000000): Unexpected status code 500 for HEAD request in Zotero.Sync.Storage.Session.WebDAV.getLastSyncTime()

    (1)(+0000000): A WebDAV file sync error occurred. Please try syncing again.

    If you receive this message repeatedly, check your WebDAV server settings in the Sync pane of the Zotero preferences.
    This is an error from your WebDAV provider. We can't help you with it.
  • Well, I'm getting the same error with another provider (box.net), is it possible something common is around?

    If that helps, I'm behind a proxy (correctly configured, but I've had some trouble with the proxy since their migration to an "unified" proxy ...).

    Just ask if you need more input.
  • A proxy could easily cause this, yes.
  • Ok, do you need more input, debug info, etc?

    I'm under linux, RHEL6.3 with latest firefox, ...
  • We don't need anything—this isn't caused by Zotero, so we can't do anything about it. And we don't debug issues with individual WebDAV servers (or proxy servers).
  • I got same problem with MAC, but my windows computer is ok.
This discussion has been closed.