LibreOffice : Missing toolbar icons (but toolbar working)


I had some trouble with Zotero and LibreOffice lately. After many re-installations, integration now works correctly but the icons are missing in Zotero Toolbar in Libreoffice : I only have text. When I click on them, it works correctly though.

I had also try this :

I did reinstall the plugin, reinstall LibreOffice, reboot my computer, re-install everything, and again and again. But it still doesn't work. Any idea ?

My configuration :

Zotero 3.0.1 with Firefox 10
LibreOffice 3.4.5
Zotero LibreOffice Integration 3.5.1
Windows 7

Please also note that I am giving a presentation of Zotero tomorrow for a group of librarian students. Zotero promotion in short. It would be nice if this could be solved before the demo ;-)

  • Hello, were you able to solve this issue? I'm having the same problem. I installed the last version of LO and the Zotero integration plugin, rebooted, done it again..but the Zotero toolbar just doesn't show up
  • I've just encountered the same problem too, with Libreoffice 3.5.3, Firefox 12, Zotero 3.0.7 and Zotero LibreOffice Plugin 3.5.2. I've tried reinstalling Libreoffice and the plugin (and Java for good measure, since Java 7 simply didn't work). The toolbar works, it just doesn't have any icons, and changing the icon settings via tools-options-view doesn't change them (it affects all the other LO icons fine).

    Rather ironically I gave a presentation on Zotero to a conference yesterday, but I doubt that's a factor!
  • This is how I solved the problem:

    1) I downloaded and installed the Zotero LibreOffice Integration plugin
    2) I opened LibreOffice but the Zotero toolbar was missing
    3) I Closed LibreOffice
    4) checked the extension in Firefox using Firefox>>Tools>>Add-ons>>Extensions
    5) in the Extensions list I looked for the Zotero LibreOffice Integration plugin and...
    6) clicked options
    7) I saw the following message:
    1. The Zotero Extension is not installed (weird)
    2. I just went ahead and clicked on “Install”
    8) I opened LibreOffice again and the toolbar was finally there

    Hope this helps
  • Thanks - unfortunately that's not the solution here - options reports that the extension is installed. Furthermore, I do have the toolbar and it is working - it just doesn't have any icons, and uses only text. 'Tis strange.
  • did you click reinstall?
  • Yes, with the same results every other time I've reinstalled the plugin (that route merely takes you to the dialogue in Zotero preferences after all) - the toolbar is there and working, but like the OP, the icons on the toolbar are still missing.
  • I just had a similar problem, but after going to Firefox>>Tools>>Add-ons>>Extensions>>Zotero LibreOffice Integration 3.5.2>>Preferences>>Cite then click on Reinstall. I can now see toolbar and icons.
  • I had the same problem. I'm running:

    Firefox 15.0.1
    Zotero 3.0 is 3.5.3.
    Ubuntu 12.04

    I uninstalled the wordprocessor plugin and the reinstalled. That seems to have fixed it.

  • edited May 17, 2013
    I have the same problem. I'm running:

    Zotero standalone 3.0.8
    Zotero LibreOffice Integration 3.5.3
    Ubuntu 12.10

    Uninstalling then reinstalling the word processor plugin does not fix the problem for me.


    After upgrading to Ubuntu 13.04, which included an upgrade to LibreOffice, LibreOffice was missing the Zotero toolbar buttons completely, so I installed the Zotero LibreOffice plugin, and the icons now appear as they should.
  • Inside the word processor plugin file is a file named Addons.xcu which contains lines like this:

    <prop oor:name="ImageIdentifier" oor:type="xs:string">
    </prop> says:

    "When you define a package containing additional files, include an .xcu configuration data file, which points to your files. Use a variable %origin% as a placeholder for the exact path where the file will be copied by the Extension Manager. When unopkg installs the data, it replaces the path with an URL containing a macro and writes into the configuration. This URL has to be expanded before it is a valid file URL. This can be done using the service. The %origin% variable is, for instance, used by the ImageIdentifier property of add-on menus and toolbar items, which is described in the Configuration section." provides more documentation. It may be that Addons.xcu needs to be revised to use a different syntax.
  • My problem is that after re-installing thousands of times, Libreoffice integration wouldn't work. it is impossible to integrate zotero and the latest version of libreoffice. The tool bar is there, though!!! but when I try to insert a citation it does not work.
  • Noemi - you may have to pick the java version in the LO options as described here:
    (generally, performing any troubleshooting step more than once or twice isn't going to help and will just frustrate you)
    Zotero works with Libre Office 3.6
  • Same problem in a fresh Ubuntu 12.10 with libreoffice and Firefox 17. The libreoffice toolbar works fine, but does not display icons. Anyone had any luck figuring it out?

    Here is what I have tried (in vain)
    * Upgrading to Java 7 and identifying it under Java in LibreOffice config
    * Installing and uninstalling Writer, Zotero, Java like a mad man, but no luck..
  • (not a general LO 3.6 or Ubuntu 12.10 issue - I have icons)
  • I too have two laptops identical setup (LO 3.6, Ubuntu 12.10 and Java 7). On one I had icons after install, while on the other no icons.. Any debug suggestions would be appreciated other than continuous re-install :-)
  • Noemi, is Zotero itself running when you try to insert a citation? I'm running Zotero Standalone, and can only insert citations in LibreOffice when Zotero Standalone is running.
  • +1

    It used to work for a couple of days after I installed the extension in LibreOffice.

    Suddenly the icons are gone, and the toolbar sits in the top left corner of my LibreOffice application window and can't be moved.

    I don't know what happened so that the icons disappeared.
  • Had same problem. Using Zotero 3.0.11 and Zotero Libre plug in 3.5.4. Firefox is 18.0.2 and LibreOffice is

    Followed Ric's process - though I didn't get the "not installed" message and pressed the Reinstall button instead - and cold-booted the machine, just to make sure. The Zotero tool bar, with icons, installed on LO and works great. Good to go.

    Thanks Ric!
  • I had the same problem and then i tried the solution here and it did the trick. Hope it helps

    "I had the same problem after upgrading to Ubuntu 12.10. Actually the solution is quite simple. Just go to the menu TOOLS>OPTIONS and search for the java section. There select the JRE installed, press OK, restart and thats all."
  • My zotero just dropped off. I reinstalled for Firefox, it is not working and there is no zotero icon to open it. It wont open in tools either. HELP!
  • start a new thread, please. This one is about the icons of the Zotero toolbar in LibreOffice disappearing, while everything else still works.
    start with the info here:
  • wlx
    edited March 7, 2013
    If you have encountered this problem but could not resolve it with the above solutions, and you are using Ubuntu 12.10, libreoffice, maybe you could try this:

    rm ~/.config/libreoffice

    then reinstall the plugin in Firefox.
  • edited April 18, 2013
    Having the same problem as stephane and daver. Toolbar in Libreoffice works, but has words instead of icons. Had a bit of trouble getting the toolbar there at all, but it is now.

    Tried reinstalling plug-in using ric's method, no luck.

    Zotero 4.0.5
    Libreoffice integration 3.5.6
    Libreoffice version
    Don't have firefox that necessary for the plug-in to work?

    *edit* Also, using Windows 7 (64-bit)
  • Hi, here the same problem.

    * Zotero 4.0.8
    * Zotero LO 3.5.6
    * LO
    * Mint 13 (Ubuntu 12.04)
    * Java: openjdk-6
  • Hi,
    Got the problem with Libre Office 4 / Windows XP and finally found a solution, but I'm not sure it will work for everyone.

    My guess is that when you switch from Open Office 3 to Libre Office 4, even desinstalling Open Office, the Application Data Open Office folder is not removed; after that, installation mixes things up and icons are not found anymore.

    To have things to work with nice small icons, I had to uninstall Libre Office, Zotero libre office plugin for firefox, remove all traces of previous installations (removing all Open Office & Libre Office folders in Application Data of all users and removing all found mention of Libre Office and Open Office in the registry). Then reinstalling all works fine.

    I thought about that because even when uninstalling the Libre Office extension and removing its folders in the user/unopackages... hierarchy, the button still appeared in Libre Office !

    Guess it can be the same when switching from version 3 to version 4 staying on Open/Libre Office, since they appear in different subfolders...

    Uninstallation of Libre Office may not be needed, cleaning up the old versions remaining folders could be enough, but not tested...

    Hope this may help!
  • Reinstallation of the plugin only worked for me after I deleted the config file for OpenOffice (~/.config/libreoffice), as suggested by wlx.
  • Hi everybody,

    I am sorry to reopen a problem you could reasonably believe had been solved. I have precisely the same problem, namely that icons do not appear while things work fine otherwise. I have tried uninstalling/reinstalling the plug-in for LO, FF, etc., but none of these has worked so far.

    This has begun when I installed the latest update of LibreOffice. (It may be worth mentioning that I have been unable to insert citations until I enabled Java in the options menu.)

    Here’s my config:
    Windows 7
    Firefox 32.0.1
    Zotero 4.0.22
    Zotero LO integration 3.5.9
    Java (JRE6): Sun Microsystems v. 1.6.0_22

    I have not tried “radical” solutions so far, out of a fear to lose the references listed in my Zotero library, or the styles I have edited, or the references listed in my works. The fact is, although I am not uncomfortable with computers, I am way closer to an “advanced layman” (at best) than to a man of science; and I wish to take all required steps in order not to mess things up.

    Thanks a lot,
  • deleting the configuration file as suggested by wlx above (though the command won't work on Windows, you need to find the corresponding file) and then re-installing the add-on has the best chance of working.
  • Thanks a lot -- After a complete uninstall of LibreOffice (including deleting the config files), and then reinstallation, the icons now appear and everything’s working fine.
  • edited February 5, 2015
    I only had to remove three folders and then relaunch libreoffice to get my icons back (and firefox to get zotero to connect). No reinstallation of the addon required.

    rm -r .config/libreoffice/4/cache/
    rm -r .config/libreoffice/4/user/temp/
    rm -r .config/libreoffice/4/user/extensions/

    Not sure exactly which one did the trick.
Sign In or Register to comment.