Not signed in (Sign In)
 

Quick Links

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

  1.  
    Is there any way to change the language (guessing by switching locale) for a single reference in the bibliography list? For APA (at least as it's used in Sweden), a reference to a book chapter in English, for example, should be written in English: i.e. Ed./Eds. instead of Red./Reds, pp instead of ss and so on.

    Any simple way to do this?
    • CommentAuthorfbennett
    • CommentTimeJan 12th 2012
     
    There is a way, but it is (as yet) non-standard (the CSL will not validate against the CSL 1.0 schema). Whether it qualifies as simple is a matter of opinion. :)

    The syntax is documented here. I'm working on more detailed documentation of this and other features available in the experimental multilingual client, for inclusion in a book (draft text available here), but I won't get to the multilingual stuff for at least another month.

    If it's only a few references, you're probably best off hand-editing in the final edit for the present.
  2.  
    I see, thanks. Although, I'm not really sure where in the CSL file I should put that in? And also, how can I tell Zotero that this or that reference should be cited in a specific language?
    • CommentAuthorfbennett
    • CommentTimeJan 12th 2012
     
    It's triggered by the "language" variable on the item, or alternatively by the default language of the style if the variable is empty. The examples under the link show how it works; you would move the content of the layout to a macro (if all you're changing is the terms, you can use the same macro for all languages), and then define multiple layouts, giving the macro as the sole content of each. Each layout but the last has a locale attribute, containing the ISO codes of the CSL-supported languages to be applied. I guess you would be defining an "en" layout, falling back to Swedish, and with the default-locale of the style set to Swedish.

    If none of that makes much sense, you're probably safer waiting until this is a little closer to showtime (!).
    • CommentAuthormaras
    • CommentTimeAug 10th 2012 edited
     
    I searched a lot to find out how create multilanguage style. So, I installed MLZ, edited this multilanguage style: https://github.com/NovemberZulu/GOST-Numeric-style-for-MLZ and added Lithuanian layout to it, identical to other layouts exept language definition. I described terms (as pages, volumes etc.) in Lithuanian locale. But this stile is not working properly because English and Lithuanian terms are mixed. So I can see Lithuanian terms (such as “t.” instead “vol.” or “nr.” instead “no.”) in Lithuanian reference and vice versa. One term may be Lithuanian, other - English in the same reference. But it is all right with Russian references and terms.

    There is no Lithuanian locale of csl. Can this be the reason of such behavior?

    Or am I doing wrong something? I've read that: http://gsl-nagoya-u.net/http/pub/citeproc-js-csl.html#multilingual-layouts and that: http://forums.zotero.org/discussion/18482/?Focus=96869 I created four layouts (last without localization) but I don't know how to "move the content of the layout to a macro". Should I define entire layout of one language inside one macro and how to do that? Or should I define only terms in such a macro? But where define look of citations or bibliography in such a case if layout must have only one macro? Examples are too simple and my experience too small.

    And this mess with multilanguage styles is main obstacle from moving toward Zotero for me. So is there any solution?
    • CommentAuthorfbennett
    • CommentTimeAug 10th 2012
     
    @maras,

    I'll be happy to look at your style, and fix any problems that turn up in testing. Can you paste the code of your style to http://gist.github.com, save it as a public gist, and post the URL from the address bar back here?
    • CommentAuthormaras
    • CommentTimeAug 10th 2012 edited
     
    Thank you for quick response.

    Here is my modification of Chicago manual style (full note): git://gist.github.com/3315481.git And Lithuanian terms overrides English ones in English references in this case. Lithuanian references are good.

    Here is slightly modified that file (only different terms in locales): git://gist.github.com/3315497.git English terms overrides Lithuanian ones in Lithuanian references there. English references are good.

    Russian terms are OK in both cases.

    I can upload my modification of GOST style too. It produces the same situation - English overrides Lithuanian, but Russian "№" overrides english "no." in English references (all other English terms are OK).

    What are my mistakes? :)
    • CommentAuthormaras
    • CommentTimeAug 10th 2012
     
    I tried to remove default locale in both documents

    <locale>
    <terms>
    <term name="accessed">žiūrėta</term>
    <term name="online">interaktyvus</term>
    </terms>
    </locale>

    but result the same.
    • CommentAuthorfbennett
    • CommentTimeAug 10th 2012
     
    Here is my modification of Chicago manual style (full note)

    We can start with this one.

    An ordinary CSL style like this one can only output with one locale setting per document; all references will be rendered in the same locale. You can switch locales (for the whole document) by changing the bibliography locale setting in Zotero.

    Alternatively, you can anchor a style to a specific language, by setting a default-locale attribute in the cs:style node (the second line of the style). You can read about that here: http://citationstyles.org/downloads/specification.html#the-root-element-cs-style

    Multiple locales in a single document are possible, following the documents you linked to, but let's get these simpler styles fixed first, and then move on to that.

    The odd behaviour you see in this style is because it is invalid (the syntax of the file is broken). You can get information on validation of CSL styles here: https://github.com/citation-style-language/styles/wiki/Validation

    Here are the validation errors in the version that you posted:

    (1) There is a nesting error at line 44. Move the closing <term/> up by two lines.
    (2) The "mont-1" etc. names need to be "month-01" etc.
    (3) The "lang=" attributes should be "xml:lang="
    (4) There is no "number" term, so that one should be removed.

    Once the style is fixed and validating, you should be able to set default-locale="lt" in the style node, reinstall the style, and switch away from the style and back in any open document to find that the Lithuanian terms are used for all items. Changing to default-locale="en" and going through those steps, you should find English terms everywhere.

    When that's confirmed to work, we'll be ready to go forward to a mixed-language style.
    • CommentAuthormaras
    • CommentTimeAug 10th 2012
     
    I fixed style, but it is not validating. Errors are about locales, as I can understand:
    Error: Attribute locale not allowed on element layout from namespace http://purl.org/net/xbiblio/csl at this point.

    From line 779, column 5; to line 779, column 60

    rue">↩ <layout prefix="" suffix="." delimiter="; " locale="lt">↩

    Error: Element layout from namespace http://purl.org/net/xbiblio/csl not allowed as child of element citation from namespace http://purl.org/net/xbiblio/csl in this context. (Suppressing further errors from this subtree.)

    From line 815, column 4; to line 815, column 60

    ayout>↩ <layout prefix="" suffix="." delimiter="; " locale="en">↩

    Error: Element layout from namespace http://purl.org/net/xbiblio/csl not allowed as child of element citation from namespace http://purl.org/net/xbiblio/csl in this context. (Suppressing further errors from this subtree.)

    From line 851, column 5; to line 851, column 60

    yout>↩ <layout prefix="" suffix="." delimiter="; " locale="ru">↩

    Error: Element layout from namespace http://purl.org/net/xbiblio/csl not allowed as child of element citation from namespace http://purl.org/net/xbiblio/csl in this context. (Suppressing further errors from this subtree.)

    From line 887, column 5; to line 887, column 48

    yout>↩ <layout prefix="" suffix="." delimiter="; ">↩

    Error: Attribute locale not allowed on element layout from namespace http://purl.org/net/xbiblio/csl at this point.

    From line 929, column 5; to line 929, column 35

    sort>↩ <layout suffix="." locale="lt">↩

    Error: Element layout from namespace http://purl.org/net/xbiblio/csl not allowed as child of element bibliography from namespace http://purl.org/net/xbiblio/csl in this context. (Suppressing further errors from this subtree.)

    From line 948, column 5; to line 948, column 35

    yout>↩ <layout suffix="." locale="en">↩

    Error: Element layout from namespace http://purl.org/net/xbiblio/csl not allowed as child of element bibliography from namespace http://purl.org/net/xbiblio/csl in this context. (Suppressing further errors from this subtree.)

    From line 967, column 5; to line 967, column 35

    yout>↩ <layout suffix="." locale="ru">↩

    Error: Element layout from namespace http://purl.org/net/xbiblio/csl not allowed as child of element bibliography from namespace http://purl.org/net/xbiblio/csl in this context. (Suppressing further errors from this subtree.)

    From line 986, column 5; to line 986, column 23

    yout>↩ <layout suffix=".">↩

    There is "fixed" style: git://gist.github.com/3316761.git

    Now Lithuanian terms disappeared completely. I set default locale to ru, lt and en. Terms are English all the time in Lithuanian and English references, but Russian terms all the time in Russian references. Changing default locale changes nothing.
    • CommentAuthorfbennett
    • CommentTimeAug 10th 2012 edited
     
    Sorry, I had missed that your first example also used a multilingual layout. That will indeed throw a validation error against the schema, but the locale attributes are the only error; the style is correct for MLZ.

    You are right that the Lithuanian locale is being ignored because it is undefined. Let me do some testing to see how best to handle undefined locales set within a style, I'll get back in a few hours.

    You might like to prepare a Lithuanian locale for use with CSL generally, by modifying the English locale file here. I'm sure the CSL group will be happy to add it to the official CSL distribution.

    (Edit: amended to reflect the link provided by Rintze below.)
    •  
      CommentAuthorRintze
    • CommentTimeAug 10th 2012
     
    Actually, if you're willing to translate the CSL locale file to Lithuanian, please use https://github.com/citation-style-language/locales/blob/1.0.1/locales-en-US.xml as the starting point. We have some translation instructions here: https://github.com/citation-style-language/locales/wiki/Translation-Instructions
    • CommentAuthormaras
    • CommentTimeAug 10th 2012
     
    Well, I am finishing locale draft. Where can I post it? I made comments in it. Some problems must be discussed. Some can be resolved in English, but for some I need help for users of Lithuanian, rather educated users :).
    • CommentAuthorfbennett
    • CommentTimeAug 10th 2012 edited
     
    It should be enough to paste the locale to http://gist.github.com, as you have done with your styles.

    For the multiple language layout issue, I did some testing and found that undefined locales (i.e. a locale defined inside the style, but absent from the CSL locale set) are recognised by the processor. There was a bug, however, that could cause selection of the incorrect locale for some items. I've fixed the bug, and released an updated version of the citeproc-js CSL processor. The simplest way to test with it is to install this plugin, which replaces the CSL processor in Zotero with the latest version.

    If you will be producing documents that span language boundaries, you might take a look at MLZ (Multilingual Zotero). This is a personal project of my own, that (among other things) allows flexible inclusion of translations and transliterations in printed citations. MLZ is not supported by the core Zotero team, and you will want to back up your Zotero database and other files before installing, but it may be useful in your environment.
    • CommentAuthormaras
    • CommentTimeAug 10th 2012
     
    There is a draft of lt_LT locale for CSL: git://gist.github.com/3318667.git Maybe better is to create another thread with questions about it?

    I have MLZ installed and it works perfectly. Thank you for it.

    I'll install new version of plugin to see how it works.
    • CommentAuthormaras
    • CommentTimeAug 10th 2012 edited
     
    I've installed plugin. No changes - English terms in Lithuanian and English references and all good with Russian ones.
    Maybe it is due bad construction of my style? It is the same as there: https://gist.github.com/3316761 I only removed default-locale.
    • CommentAuthorfbennett
    • CommentTimeAug 10th 2012 edited
     
    I'll be working on another task for a few hours, but I'll take a look. If you're using the latest version of MLZ (m224), you won't need the processor plugin; it already contains the latest processor version.

    One thing to confirm before I take a look: do you have "lt" set in the Language field of your Lithuanian entries? That's what should trigger the language switch. If that's in place, and the only errors in your style are those locale attributes, you may be experiencing a lingering bug in the processor. I'll take a look in a few hours.
    •  
      CommentAuthorRintze
    • CommentTimeAug 10th 2012 edited
     
    There is a draft of lt_LT locale for CSL: git://gist.github.com/3318667.git Maybe better is to create another thread with questions about it?


    Yes, please. (and it's slightly handier for us if you copy/paste the URL from the address bar, like https://gist.github.com/3318667, instead of git://gist.github.com/3318667.git )
    • CommentAuthormaras
    • CommentTimeAug 10th 2012 edited
     
    @ fbennett,

    Yes, I see, that my Zotero is 3.0m224.
    O yes, I have locales defined. Actually, I am "playing" now with selected types of references and locales: I am testing, how different styles display them. Sometimes I am changing language field from "lt" to "ru" or "en" of selected entries. With "ru" and "en" there is no problem - after such a change terms of references in Writer document also changes (after refresh), as in Zotero CSL Editor or CSL preview. But references in Lithuanian are stuck to English.

    @ Rintze,
    sorry, I didn't notice that.
    • CommentAuthorfbennett
    • CommentTimeAug 11th 2012 edited
     
    @maras: We owe you a round of applause.

    The Lithuanian terms in your style were not turning up due to a processor bug that caused locale nodes with specific xml:lang attributes to be masked in all styles, in both official Zotero and in MLZ. This must have been confusing to many style authors, and I'm very glad get it fixed.

    If you update MLZ to the latest (m225), you should find that your style works as expected. For completeness, you might want to add all of the relevant nodes (style-options, date, and terms) from the locale you have prepared to the style, until your locale makes its way into a CSL release.

    Let me know if you run into any more snags; but I think the tool will start doing its job for you now.

    (Edit: If you haven't yet made major changes to the Chicago Fullnote style on which you're basing your work, you might take a look at the MLZ Chicago Fullnote style as an alternative. It validates against the MLZ extended CSL schema, which permits the multiple layout syntax. Validation works in the same way as for official CSL, but using the alternative schema. (I'll be reorganising the schema source soon, but that repo address will always contain the multilingual version.)
    • CommentAuthormaras
    • CommentTimeAug 11th 2012
     
    I updated MLZ to m225 and... still no luck. I even created two new styles (from MHRA and MLZ-CMS-full), by adding "ru" and "lt" locales to existing "en" and quadruplicated theirs layouts of citation and bibliography ("en", "ru", "lt" and without locale at the end). No other changes. Just to be sure, that not styles created that mess. All of them are not working. Some of them adds Russian terms to Lithuanian references, some - English terms. Lithuanian terms appears only after removing from locale "xml:" before lang="lt". But that creates mess in English and Lithuanian references (some terms Lithuanian, some - English in both, Russian - intact). I can only guess, that processor searches Lithuanian xml file when "xml:lang="lt"".

    I am only testing styles and locales and therefore I am doing only essential changes to styles as described.

    Is there opportunity to validate MLZ styles with validator.nu? I pasted this link: https://github.com/fbennett/schema/tree/multi to schemas field in it, but it validates all, even truly wrong styles.
    • CommentAuthorfbennett
    • CommentTimeAug 11th 2012
     
    It definitely tests correctly here. It's late here, I'll be going to bed. If you can paste a style that fails for you, and data that fails with it (exported as Zotero RDF), I'll see if I can reproduce the behaviour you describe tomorrow morning.
    • CommentAuthormaras
    • CommentTimeAug 11th 2012
     
    Thank you for you patience and help :).
    There is my style modification: https://gist.github.com/3325436
    There is my references: https://gist.github.com/3325361 Actually they are only for testing purposes, so they aren't real but created to fill as much fields as possible. Two of them are Lithuanian, one - Russian and one - English.
    Hope this will help.
    • CommentAuthorfbennett
    • CommentTimeAug 11th 2012 edited
     
    The style is throwing some English terms in the Lithuanian locale because the Lithuanian term set defined in the style is incomplete, and English is used as an ultimate fallback. Here is a version that includes all of your defined locale terms, which seems to work normally: https://gist.github.com/3328311

    Validation against the MLZ extended CSL schema is a little awkward at present. I'll try to set up an easy validation channel sometime fairly soon, but you should be good with the style above for now.

    (Edit: I made one small set of changes to the processor, to handle the switching of punctuation-in-quotes behaviour across locales in a multi-layout style. You can pick up the changes by updating MLZ.)
    • CommentAuthorfbennett
    • CommentTimeAug 11th 2012 edited
     
    Some of them adds Russian terms to Lithuanian references

    The only way I was able to reproduce this was by setting default-locale="ru" with an incomplete set of Lithuanian terms. In that case, Russian is used as a fallback, and some Russian terms show through in Lithuanian entries. If the Lithuanian locale is fully defined, the terms seem to come out consistently in one language. If you do see mixed terms in cites with a fully defined Lithuanian locale, though, do let me know; that should never happen.
    • CommentAuthormaras
    • CommentTimeAug 11th 2012
     
    Well, now all terms in Lithuanian AND English references are... Lithuanian. I even pasted all en_US locale to en locale of style, but no effect at all. And all OK with Russian references.
    I upgraded MLZ.

    There were some issues with the style file - bigger half of it was red when opened in Gedit. Because some remarks (in <!-- -->) maybe broke the code itself (apostrophe in "don't"). I don't know how this affected code. But there was no changes after I corrected that.

    I think, that these problems will vanish after Lithuanian locale adding to Zotero. But there is languages without locales and it is not good if such a problem will continue.

    Or problem is with my style.
    How my style, modified by you, behaves with English references?

    Now I am going to bed :).
    • CommentAuthormaras
    • CommentTimeAug 11th 2012 edited
     
    I think, I managed to success! It is all right with all the languages and terms by setting default-locale="en" of style. Maybe multilingual style must have default locale?

    (Edited. But when default locale is set to "ru" or "lt", all terms are Lithuanian of English and Lithuanian references and Russian - in Russian. I have one idea and will test it soon.)
    • CommentAuthorfbennett
    • CommentTimeAug 11th 2012 edited
     
    Here's what I get with those references and the style I linked above:

    http://img805.imageshack.us/img805/816/mixedlocales.png

    That's all correct, I think.

    Be sure that the language attribute in the locale nodes is set with xml:lang=, and not with plain lang=. The latter is not recognized, so that node would become the fallback. If a locale node in the style was set to <locale lang="lt"> with a full Lithuanian set of terms inside, that would produce the behaviour you describe (i.e. Lithuanian everywhere, unless overridden). But that's just a guess.

    For final debugging, I'll need to see exactly what you are using for the style and for the entries for a specific error. The major wrinkles have all been ironed out, as far as I can tell; the problems are almost certainly with the input, and I'll need to see it directly in order to track down the cause of odd behaviour.

    (Edit: we crossed in the post -- response below.)
    • CommentAuthorfbennett
    • CommentTimeAug 11th 2012 edited
     
    Yay, that's good to hear. The fallback locale can be a little tricky; if a style has no default-locale, the fallback used would (I think) be the Firefox locale, or (maybe) the one that shows in MLZ Preferences -> Languages next to "CSL:". I assumed that it would be English, but it could of course (facepalm) be different in your environment.

    For styles that use multiple layouts, I think our experience today suggests that setting default-locale on the style is indeed a good idea. :-)

    (Edit: crossed in the post with your qualification above. Will look forward to hearing what you turn up. When you have a stable set of data that misbehaves, send it along and I'll take a look.)
    • CommentAuthorfbennett
    • CommentTimeAug 11th 2012 edited
     
    With default-locale="ru", I do get bad output here, with Lithuanian terms in an English entry. This absolutely should not happen. I'll take a look. With luck you'll find it's fixed tomorrow morning.
    • CommentAuthormaras
    • CommentTimeAug 11th 2012 edited
     
    Yes, my guess was correct. I've just installed old variant of this style, that wasn't working - without all Lithuanian locale, only some Lithuanian terms described. All terms of English and Lithuanian references were Lithuanian in it. BUT all was corrected when I've set default-locale="en" in style.
    But I must default locale set to "lt" in other bad my style to get it working properly.

    (Edited. So, this depends not on Firefox (Iceweasell in my Debian) or on MLZ preferences.)
    • CommentAuthormaras
    • CommentTimeAug 11th 2012 edited
     
    I think, I found what is going on.
    default-locale must be set accordingly to how layouts are lined up in citations and bibliography, how to say, nodes.

    1st style, where default locale should be lt. Layouts were in such order (from top, to down): en, ru, lt.
    2nd style (default locale should be en). Order: lt, en, ru.

    So, default locale must be that of layout above layout without locale. But not ru. Setting ru locale changes nothing or creates bad output. Maybe that is cause of such inaction of ru locale?

    (Edited. One more style with order: en, ru, lt, default locale must be lt.)
    • CommentAuthorfbennett
    • CommentTimeAug 11th 2012 edited
     
    Thanks for your work and feedback. It's useful to know that sequence can change things. According to the CSL specification it shouldn't matter, though, so this needs to be fixed in the processor. I should have a solution in a few hours.

    (Edit: the spec link in this post is off the point: I misread, and assumed you were talking about sequence of the cs:locale nodes, not cs:layout. The fault has been fixed, though; see below.)
    • CommentAuthormaras
    • CommentTimeAug 12th 2012 edited
     
    And something is wrong (or good) with Russian layout/locale - changing its position changes nothing. But sometimes it creates bad output.

    One more experiment. I changed order only in one section of style - bibliography. So order in bibliography: lt, en, ru; order in citation: en, lt, ru.
    Default locale - lt. Lithuanian reference - Lithuanian terms are everywhere. English reference - Lithuanian terms in bibliography, English - in citation.
    Default locale - en: all vice versa.
    Russian in both cases - OK.

    Now I'm going to bed really :).
    • CommentAuthorfbennett
    • CommentTimeAug 12th 2012 edited
     
    If you update, I think you'll get better results, again. The sequence of the cs:locale declarations doesn't matter. The sequence of cs:layout + xml:lang declarations should also now be irrelevant, with two exceptions: (1) the final layout should have no xml:lang attribute; and (2) if you are matching variants of the same language (such as zh and zh-TW), the more specific variant should be above the less specific one.

    The cause of this most recent (and hopefully final) fault was that it was retrying for a match between the item language fallback locale and the list of available locales, rather than against the one-element version of the item locale and those available. The fallback for "lt" (and any other non-standard locale) is "en-US", which is always available, so it was finding a match as soon as it hit that cs:layout node, and that was very wrong indeed.
    • CommentAuthormaras
    • CommentTimeAug 12th 2012 edited
     
    m227 now.
    Results the same. I used the last example with different order of layouts in bibliography and citation (order in bibliography: lt, en, ru; order in citation: en, lt, ru).

    So:
    locale en: all good with en and ru references, but lt references are with Lithuanian terms only in bibliography.
    locale ru: all OK with ru, lt and en references with lt terms in bibliography.
    without locale: same as with locale ru
    locale lt: all good with ru and lt references, Lithuanian terms in en bibliography.

    (Edit. Other style with alike order in bibliography and citation had correct terms only with "correct" default locale.

    Edit 2. I didn't touch order of locales, only order of layouts in bibliography and citation [nodes?]. And sorry for my English - it isn't good indeed. :))
    •  
      CommentAuthorRintze
    • CommentTimeAug 12th 2012
     
    Validation against the MLZ extended CSL schema is a little awkward at present.


    How so?
    • CommentAuthorfbennett
    • CommentTimeAug 12th 2012
     
    @maras: I'll need the style code and item data for one specific failure.

    @rintze: Simon's validator looks very simple to explain and to use. I've forked the repo, but haven't yet recompiled the code with the MLZ schema.
    • CommentAuthorfbennett
    • CommentTimeAug 12th 2012
     
    @maras: Good news, I have a failure. Citations are assigning the correct locale, but I can confirm the behaviour you describe in bibliographies. This gives me enough to investigate; you don't need to send style code and item exports. More soon ...
    • CommentAuthorfbennett
    • CommentTimeAug 12th 2012
     
    @maras: Another MLZ fix just went up (m229). Here's what it's producing with local test data: http://img801.imageshack.us/img801/5932/multitest.png

    Hoping for good news, thanks for your patience. Despite the repeated glitches, we're getting close with this.
    • CommentAuthormaras
    • CommentTimeAug 12th 2012 edited
     
    Well, situation is the same: http://imageshack.us/g/827/20120812235618.png/ English reference. Terms are correct only with en layout (it is on the bottom of layouts). And there is no difference between citations and bibliography.

    Maybe it's not a bug, but a feature, as layout without locale, that must be on the bottom. As for me this situation is not bad at all.
    Only one thing should be done - short instructions should be written about creation of multilingual styles with warning about order of layouts.

    But something isn't good, because Russian layout isn't working as default. Maybe it's fault of Russian locale.

    I can send you styles and examples, but this situation is with all my multilingual styles.

    By the way, this tool: http://steveridout.com/csl/visualEditor/ always cuts out "xml:" from all locale names. I've send bug report.

    (Edit. I think, Russian layout is working because Cyrillic of it - there is no other fallback, only one Cyrillic style.
    One more idea. My MLZ locale - en_US, but "general.useragent.locale" of Firefox - lt. Maybe this creates mess of languages to processor.)
    • CommentAuthorfbennett
    • CommentTimeAug 12th 2012
     
    In csledit.xul and in documents, I'm getting consistent and correct results for all combinations, including those with no default locale, and with default-locale="lt", and with general.useragent.locale set to "lt".

    Entries with no locale or an invalid locale are rendering in the default language, and valid language codes on an item force its terms and formatting to that locale. I can't produce output like that in your screenshots with the current MLZ version.

    It's likely that there is a problem with your input. Please post your item data and the exact style code that you are using for testing to http://gist.github.com, and I'll take a look.

    The editor at http://steveridout.com/csl/visualEditor/ will not (yet) work with MLZ styles by default, because it relies on the official CSL 1.0 schema. The developer has set up a means of configuring the editor to work with MLZ styles, but there are some bugs that need to be worked out before it's ready for use.
    • CommentAuthorfbennett
    • CommentTimeAug 12th 2012
     
    There will be documentation, and soon. I'm working on a book about MLZ, and multilingual layouts will be described there -- so I'm particularly keen to see that it's working correctly!
    • CommentAuthormaras
    • CommentTimeAug 12th 2012
     
    Maybe this is my fault - I only beginner in writing styles.

    There is the same style as in screenshots: https://gist.github.com/3334891 All is OK with default locale en, but not lt or ru - Lithuanian terms then dominates in English references (not editor - it isn't translated here). There is only few terms described in lt locale. But I think, such a situation better reflects situation of ordinary user that can't create own locale for language.

    There is the same reference as in screenshots: https://gist.github.com/3334921
    • CommentAuthorfbennett
    • CommentTimeAug 12th 2012
     
    Here is what I get with that style and item:

    default-locale="lt": http://img809.imageshack.us/img809/9338/ltconfirm1.png

    default-locale="ru": http://img36.imageshack.us/img36/5937/ltconfirm2.png

    Both render the en-tagged item with English terms. This is with MLZ m229.

    My guess would be either that MLZ is not yet at version m229, or that this style code has somehow not installed.
    • CommentAuthormaras
    • CommentTimeAug 12th 2012
     
    MLZ is m229. I'll uninstall style, reboot computer and install the same style :).
    • CommentAuthorfbennett
    • CommentTimeAug 12th 2012
     
    Here's a thought: have you uninstalled or disabled the Zotero Processor plugin? If not, disable it; it is not needed with MLZ, and unless it is upgraded as well, it will replace the (newer) processor in MLZ with the older version embedded in the processor plugin.
    • CommentAuthormaras
    • CommentTimeAug 12th 2012
     
    Yes, you were absolutely right. All the problems gone after uninstalling Zotero processor gadget. At last!

    Sorry for troubles.

    And I think, that last bug you found because my complaints, was not the same as those, about which I was complaining :). But bugs were real, so not so bad.

    Thank you very much for assistance and help.

    Is MLZ updating automatically via Firefox or I must do it manually via your site?

    Now third (and most complicated) stage of transition from EndNote to Zotero is before me - create styles that suits my needs. They should be humanitarian ones and that means - very complicated.
    • CommentAuthorfbennett
    • CommentTimeAug 12th 2012
     
    Yay! Thank you for patiently navigating the undocumented forest. We were indeed speaking at cross-purposes, but we were both listening, and that's what counts. :-)

    I'm not sure if MLZ updates automatically. I think it does, but the "Find updates" item in the Tools -> Add-ons -> Extensions -> MLZ context menu certainly does work.

    When I get a make-easy validation engine in place for MLZ styles, I'll post back to this thread. Meanwhile, don't hesitate to write again if you have problems.
    • CommentAuthormaras
    • CommentTimeAug 22nd 2012
     
    And my problems again :).

    I've almost wrote my multilingual style (it validates), but Lithuanian localization is working quite strange for me. Date style is not Lithuanian, but English and so on. Date style became Lithuanian only after inserting all Lithuanian locale to my style.
    Is Lithuanian locale working in Zotero? Rintze added it to repository: http://forums.zotero.org/discussion/24804/some-csl-lithuanian-locale-translation-problems/#Item_17 My MLZ version - 232.

    And one more strange thing. Ordinals became Lithuanian even in English references after insertion of Lithuanian locale to style. So edition isn't "2nd", but "2asis".

Zotero Forums are powered by Vanilla 1.1.5a