Zotero Standalone + Ubuntu 11.10 PDF display

Minor issue I'm having:

When I try to display a stored .pdf using Zotero, it asks me to select a pdf reader - no problem. I pointed it to /usr/bin/evince and that was that.

The annoyance is that zotero pops open a blank window whenever I open a .pdf! Evince runs, and displays the document, but underneath that is a blank window (titlebar just says "Zotero".) If I open multiple .pdfs I don't get multiple blank windows, but if I close the blank window, it will reappear the next time I open a .pdf through zotero.

Can anyone else re-create this problem?
  • Thanks, Dan - but I think I may be having a different problem. I deleted mimetypes.rdf in my firefox profile, and tried changing launchNonNativeFiles, both to no avail. It launches evince, displays the file, but only after throwing up a blank window labeled "zotero"

    For reference, I'm running 64bit Ubuntu 11.10 with zotero standalone and a zotero connector for Chrome.

  • By my reading that's the exact same problem as in the other thread, no? We don't have any information on this other than what's there.
  • Well, tab vs. window, but that's probably just a function of Firefox vs. Standalone.
  • To be clear, any mentions of "Firefox" there should be read as "Standalone" in your case. Standalone has its own mimetypes.rdf and about:config (accessible via the Advanced pane of the prefs) and profile.
  • Thanks for the clarification, Dan.

    The problem persists - I purged both the mimeTypes.rdf files that are buried in my .mozilla and .zotero directories. I added evince to defaults.list - but nothing seems to work.

    I'm interested to know if anyone else is having similar issues with zotero standalone + Ubuntu. Until then, I'll keep poking around.

  • I just reproduced this. It does seem like the same issue from the other thread in that it looks to me like it is launching the browser window that would be used to view a snapshot but then that window launches the pdf instead and doesn't close itself.

    Last line in debug for it:
    (3)(+0000227): launch() not supported -- passing file to loadURI()
  • Yes, I have the same problem with standalone on Ubuntu Oneiric. The empty window is very annoying. Does the DOI and URL links work for you in the info panel? I wonder if that is a related problem.
  • So this happens in tab mode in Firefox and in Standalone—places where there's no active browser window—when OS-based file launching (i.e., nsILocalFile.launch()) fails. That seems to be the case in Standalone on Linux, though it works for me in Firefox 8 on Ubuntu 11.10. We're looking into whether direct launching is fixable in Standalone.

    Regardless, I've made a change to the fallback on the 3.0 branch that should prevent the empty window from appearing. Instead, when file launching fails, you'll get the Mozilla external helper app dialog, and you can select evince or another program. Currently, if you then choose "Remember by choice for file links", I think the only way to change the setting would be to delete mimeTypes.rdf from the Standalone profile. We can probably offer another way to reset that from the preferences.

    The fix will be in 3.0b3.
  • edited December 20, 2011
    another possibly a bit related question: i'm used to keep the literature i want to read open as zotero links in firefox (8.0). now, whenever i restart firefox, zotero (2.1.10) opens up all the pdfs in separate windows, even though i set the "application/pdf" preference to "use adobe in firefox". no settings were changed by me (i do have noscript installed).

    additionally, when i now open up one of the pdfs stored in zotero, i always get an external window AND i don't get the usual "zotero://attachment/***/" that i now have for the files i've opened before. launchNonNativeFiles is at "false", i'm using adobe reader X since a few weeks.

    this happens regardless of zotero being in full screen mode or not.

    how can i go back to viewing the pdfs in firefox? any ideas? thanks a bunch for having a look into this!
  • Zotero just passes file handling on to Firefox (or the OS, when launchNonNativeFiles is set to true) you'll have to play FF's file handling if this isn't working right for you.
    Especially if you're on Linux, see here:
  • edited December 20, 2011
    ty for your reply, adam, works!
  • I can confirm that the empty window problem has been corrected in the latest beta 3.0b3.1

    Thank you!
  • We've made an improvement to this workaround that should avoid the use of the external helper app dialog on most systems. Details here:

Sign In or Register to comment.