Zotero, Ubuntu 11.10 and Libreoffice

I just upgraded to Oneiric (Kubuntu 11.10) and Zotero no longer plays nice with Libreoffice. I was using Libreoffice and Zotero 3.0 standalone on Kubuntu 11.4. Under 11.10 I've tried sun-java as well as openjdk. The programs load as they did before but as soon as I try to use the Libreoffice extension to add a citation or refresh the bibliography, Libreoffice crashes. Has anyone else had success? Any recommendations?
  • the java version doesn't matter - the plugin doesn't use the system java anymore.
    This happens with a fresh document? And "crash" means just close? Or does it freeze or throw an error?
  • Thanks for the quick reply. I tried with a fresh document and was able to insert a citation just fine. When I added a bibliography, however, it crashed again. Yes, by crash I mean it just closes. It does not freeze nor throw a visible error though I'm sure there's a .log or core dump somewhere. If you need more diagnostic data please walk me through the steps to generate that data.

    Thank you for your help!
  • edited October 16, 2011
    I have not yet tried the standalone version (or Kubuntu 11.10), but I can tell you that on a very default system as booted from a live CD Zotero works fine with the Firefox and Libreoffice that come with Ubuntu 11.10, after the installation of OpenJDK 6 and another package as requested by the integration plugin (possibly libreoffice-java-common).
  • I've also upgraded to Kubuntu 11.10 and suffer from the same problem.

    I can insert citations normally, the citation numbers appear in the document as they should. (Integration IS partially working.)

    However, when I try to insert bibliography, libreoffice (LibreOffice 3.4.3 OOO340m1 (Build:302)) crashes (simply disappears).

    I do have libreoffice and all its components installed. I've tried to reinstall libreoffice and reinstall the zotero extension, but the bibliography importing is still, unfortunately, not successful.

    Also I have default-jre and openjdk-6-jre installed, if that is of significance.

    I tried to look for a libreoffice error log, but was unable to find it. Any suggestions? Thanks in advance!
  • Hi again!

    I realized I could get some more info by running libreoffice in the console and reproducing the crash.

    The last console entries before crashing are:
    ZoteroOpenOfficeIntegration: Received message ["Document_insertField",["ReferenceMark",0]]
    QPixmap: It is not safe to use pixmaps outside the GUI thread
    QPixmap: It is not safe to use pixmaps outside the GUI thread
    QPixmap: It is not safe to use pixmaps outside the GUI thread
    QPixmap: It is not safe to use pixmaps outside the GUI thread
    # A fatal error has been detected by the Java Runtime Environment:
    # SIGSEGV (0xb) at pc=0x01ad1a46, pid=4304, tid=2915629936
    # JRE version: 6.0_23-b23
    # Java VM: OpenJDK Client VM (20.0-b11 mixed mode, sharing linux-x86 )
    # Derivative: IcedTea6 1.11pre
    # Distribution: Ubuntu oneiric (development branch), package 6b23~pre10-0ubuntu5
    # Problematic frame:
    # C [libQtGui.so.4+0x258a46] QX11PixmapData::createCompatiblePixmapData() const+0x156
    # An error report file with more information is saved as:
    # /home/petri/hs_err_pid4304.log

    You can download the full console output here:

    The said error report file is here:

    I hope this helps fixing this issue!
  • edited October 18, 2011
    This sounds like the same issue as was reported with the OpenOffice.org Qt VCL plug-in a couple years back. Can someone try the old fix and see if it works?
  • Yes, it works now smoothly.

    I simply uninstalled the KDE integration package (libreoffice-kde).

    I can now insert citations and bibliographies without incident. And there is no saving issues, like it was mentioned in that old thread Simon brought up.

    Thanks for the fix!
  • I can confirm the same: using Libreoffice and Kubuntu 11.10 zotero crashes when inserting/refreshing bibliography. Same configuration but with ubuntu 11.10 works perfectly, which means that it has to be something about KDE or Qt.

    I've red that it would work by uninstalling KDE integration package, but I'm not sure of wanting to do that. Are there any other workarounds?

    Thank you

    PS: Kubuntu users I'm having problems with Libreoffice, from time to time non-printable characters dissapear, no matter if I click on the icon or not. I'm afraid there's something wrong with Libreoffice in Kubuntu
  • I confirm exactly the same bug !
    I confirm that workaround consisting in remove libreoffice-kde solve the problem !

    Thanks to you wyeager to have reported this bug, and thanks to Simon and petri.m.pulkkinen for the workaround, you save me lots of time !

  • I experienced the same bug, solved it by uninstalling libreoffice-kde. All fine now, thanks for reporting.

    Libreoffice runs faster than ever before (I'm still on sun-java 6.21) and I can live without kde looks
  • Thanks all - I'll put this into the troubleshooting asap.
  • I have reported this in Launchpad also. Thanks for the fix.
  • According to the link above, this should be fixed soon in an update to LibreOffice.
  • The same problem for LibreOffice 3.4.2 (stable) or 3.4.4 for Opensuse 12.1.
    Deinstalling KDE4 integration "solves" the problem.
    I had the same problem about two years ago with OpenOffice and the KDE4 integration.

    Best wishes

Sign In or Register to comment.