Some menus in Zotero standalone appears in Swedish

This is supposed to be a bug report. Is this the place to send it?

I have just installed Zotero standalone beta 3.0b2.1. I am using Windows 7 (which is fully up to date, of course), the English version. However I am using Swedish keyboard etc.

Some of the text I see in Zotero standalone is in Swedish. For example the Tools menu looks like this:

Skapa tidslinje
Läs in RTF

As you can see the first two menu entries are in Swedish.

TIP: I have seen this problem in other developing software. Some code is just reading the wrong values, checking keyboard layout instead of language used in menus etc.

    The locale switching behavior is determined by Mozilla code (the intl.locale.matchOS preference in particular). Since it's upstream code, I am inclined to believe it reads the correct values unless proven otherwise. Are you sure you don't have the locale (and not just the keyboard) set to Swedish, which is possible even on an English version of Windows?
  • I have not seen problems with languages in Firefox (as I can remember at the moment). When I look a the Zotero plugin in Firefox everything is in English.

    Which setting are you thinking of then you say "locale ... set to Swedish"?

    I do have the "Language for non-Unicode progams" set to Swedish:

    Control Panel
    Region and Languages
    Language for non-Unicode programs

    But that is a character setting, not a text setting. (I.e. my setting tells Windows to use Latin-1/ISO 8859-1 for the characters in those programs.)
  • Ping! Is there anyone looking at this bug? Do you need more information?
  • this is not a bug, or at least not a Zotero bug. Presumably
    reads the locale from the language for non-unicode programs.
  • It is definitively a bug. And as tried to explain very likely a Zotero bug. Is there anything that is not clear in my explanation? (I have been through this in a much more technical application than this.)
  • It's not a Zotero bug. It's an upstream bug in XULRunner. You would need to report that intl.locale.matchOS is using the wrong locale at

    But for now, I'm pretty sure you could set the language for non-Unicode programs to English, which AFAIK also uses ISO-8859-1.
  • Also, XULRunner just calls LCIDToLocaleName, which is a function in Windows, to retrieve the system default locale. I would guess that on your system, the system locale is Swedish but the user locale is English. If this is the case, you would need to convince Mozilla that intl.locale.matchOS should use the user locale and not the system locale.
  • Thanks Simon, I have no C compiler here so I can't check it easily. However all text is in English on my pc (except for those menu entries in Zotero ;-).

    Can I see this "system locale" setting somewhere?

    (And also if this turns out to be in XULrunner, do you know where to report it? Mozilla Core, or?)
  • You would need to report that intl.locale.matchOS is using the wrong locale at
  • Thanks adamsmith, but I did not know which component to report it in.

    Simon: I installed a C compiler. Your guess was correct, my system locale is actually Swedish (but where does that show up???) and my user locale is English.

    I am a bit surprised by that ;-)
    So I submitted a bug report here:
  • have you tried setting intl.locale.matchOS in the about:config as false?
  • @asplundj: The problem with the language above is for Zotero Standalone. Is there an about:config for this somewhere?
  • edited October 26, 2011
    Yes it is you'll find it in standalone at
    Preferences (the gearwheel)->Advanced->Open about:config

  • Thanks asplundj. That turned all the text into English. Very convenient ;-)

    (However the bug of course still remains and lurks somewhere...)
Sign In or Register to comment.