Zotero Standalone lookup broken

With Zotero SA I don't get any reaction from the lookup buttons to search for a reference. In principle this should open a browser window or use an already opened browser window (probably firefox or konqueror) and list Google Scholar's entries for the item.

I also cannot obtain any response in SA when I click on any URL link in the item details panel or on a web-page item.

Is this normal behaviour for ZSA 3.0b2 in Fedora 15? How can I specify an external application to open web-based links? When I first used it, opening a .pdf item would ask for an external app to use, but after that it would remember the settings. But with html items it just sits there... Turning on the error log message doesn't provide much of a clue either.

Since no one else seems to be complaining about this should I conclude that it's a specific thing for ZSA 3.0b2 in fedora 15?
  • I have the same issue running standalone on Ubuntu Oneiric Ocelot. URL or DOI in details pane does not work.
  • It looks as though this is broken in 3.0b2.1 on Linux, but not on OS X or Windows. I'll take a closer look.
  • I take that back. It works fine for me on Ubuntu Natty Narwhal, so this may just be a configuration issue. Unfortunately, I have no idea how this functionality works, because it's something built into the Mozilla codebase. I'll try installing Oneiric Ocelot and see if I can reproduce it.
  • I know the original post related to zotero standalone, but I'm
    seeing something similar (?) in zotero firefox.

    I just "upgraded" to Ubuntu 11.10 ("ocelot") and zotero plugin
    for libreoffice no longer works for me. The zotero buttons appear
    in the lo toolbar but nothing happens when I click on them
    (specifically, no firefox dialog window opens).

    I have reinstalled zotero and the lo integration extensions in
    firefox, but it makes no difference.

    I have checked that java is enabled in lo; indeed, I have tried
    all four different java installations that lo located, but it
    makes no difference.

    If I try lo with no firefox already running it makes no
    difference either.

    If I start lo within a terminal, I get the following logged there
    when I try a zotero button:
    ZoteroOpenOfficeIntegration: Service initialized
    ZoteroOpenOfficeIntegration: Executing setDocPrefs
    ZoteroOpenOfficeIntegration: Comm initialized
    ZoteroOpenOfficeIntegration: Iterating mainLoop
    ZoteroOpenOfficeIntegration: Sending message "setDocPrefs"
    ZoteroOpenOfficeIntegration: Iterating mainLoop
    This suggests to me that the integration component in lo is at
    least running (so not a java issue as such? maybe?) but something
    is failing in the communication with firefox.

    Any ideas for how to investigate further would be welcome!
  • Hmmm ... for what it's worth, I now have lo-zotero-firefox
    working again, but am not absolutely sure how ;-)

    First I did a full restart (which I had not done up to then,
    after re-installing the zotero firefox extensions). That seemed
    to make "something" happen - I was at least getting some response
    to the zotero buttons in lo, but detailed behaviour was still

    Secondly, I limited myself to just one instance of firefox
    running on the machine. To explain: in my particular context, I
    typically have multiple ubuntu sessions running, with different
    users, so that I can quickly switch between different
    contexts/environments. This does mean that I typically have
    multiple firefox instances running on the one machine, albeit
    under different logged in users, in different ubuntu/gnome
    sessions, which therefore should not interact or interfere with
    each other. Nonetheless, it seems that, in the specific case of
    lo-zotero-firefox integration, the integration component may get
    confused by this. Or at least, it was only when I exited all but
    one instance of firefox that I got it working more or less
    reliably again.

    I don't know whether this is exclusively something new on ubuntu
    11.10 or not. I was previously running 11.04 ("natty"); I was
    also using a "lighter-weight" mechanism for concurrent user
    sessions (different logins, but within one gnome session). I did
    sometimes encounter some flakiness in the lo-zotero-firefox
    integration, but not the consistent breakdown I saw today.

    Anyway, your mileage may vary: but if you are ever running
    multiple firefox instances and see erratic lo-zotero-firefox
    behaviour, it may be worth switching down to just a single
    concurrent firefox instance, just to be sure...
  • This is a sorely missed feature in the standalone version for Ocelot. Is there any progress in understanding this issue?
  • The problem with URL and DOI links not working in the Info details pane persists in 3.0b3.1 on Ubuntu Oneiric.
  • OK, I found something that works. Close Zotero and open your favorite terminal:

    cd /usr/lib/x86_64-linux-gnu/
    sudo ln -s libnotify.so.4.0.0 libnotify.so.1

    Start Zotero and try a DOI or URL link. It should open in your browser.
    I guess the location of libnotify can vary depending on architecture and distribution. I don't know if this is a solution or a workaround.
  • edited January 20, 2012
    I just committed a workaround for this (and file launching/revealing) that uses xdg-open by default.

    We suspected that libnotify was the problem but hadn't tried symlinking—nice find. We might be able to recompile XULRunner to fix this properly, but hopefully xdg-open will work on most systems.
Sign In or Register to comment.