(Barcode) Scanner for Zotero android application

I just want to let everyone know that there is now an Android app, Scanner For Zotero, which allows you to add books to your Zotero library (or a group library) by scanning an ISBN barcode. It also allows you to edit the bibliographic information, take notes, and add tags prior to uploading the item to your library.

The version on the market costs 2 USD, so that I can hopefully recover some of my development costs, but please only download that version if you enjoy the product and can spare the small donation. The source code is GPLv3, and you can download the same .apk installer which is on the market, for free, on github.
  • Hi! I've just found your app and I quite like it so far. Thank you for creating it!

    Just one issue: I can't seem to access group libraries. I create an private key which allows Read/Write access to all current and future groups, but when I try to select the library in the app, nothing shows up. I also tried setting the per group permission, but with the same result. What am I doing wrong?

    May thanks in advance!
  • Ah, yeah there's no way to refresh your group permissions after they've been retrieved from the Zotero server. You'll need to force the scanner to forget your permissions. Log out of the scanner (Menu -> Log Out), then from the login screen hit Menu -> Manage Keys, long press on the key giving you trouble and hit Delete. Then log in again as you did the when you first installed the scanner.

    Sorry for that oversight, I'll put a refresh button in the next release.
  • Thanks for your quick reply!

    I removed all the stored keys from the app, and for good measure, I also revoked all keys from my zotero account. Then I created a new key, giving the scanner read/write access to all my current and future groups. But again, once I'm logged in and hit 'Select Library' I could only select My Library (ie, my personal library, no groups).
    Then I created a key with both read/write access to all groups, and read/write access for all individual groups checked, but when I tried using that key, the app keeps crashing, before I have the opportunity to change any settings. So then I ended up uninstalling and reinstalling the app, tried some more permutations of the key settings, but nothing gives me access to group libraries - I only every get access to My Library.
    Uploading to My Library works fine, and from there I can of course move the newly entered books to any group library I want - so that works fine as a workaround. Still, I can't figure out what I'm doing wrong.

    Another tip for the next release: it'd be great if the list of scanned books could somehow be saved. They now seem to be linked to the API you're logged in with, but if uploading with that key fails, there is no way (that I could find) to upload them using another key. Also, it'd be great if there'd be a way to export the barcodes that were unrecognized, so I can search for those manually.
  • Thanks for the feature ideas! I wasn't able to reproduce the crash you mentioned, but it does seem that the only way to get the group list is to use per-group permissions. If you can reproduce the bug and hit the "Report" button instead of "Force close", I'll see if I can get that fixed for you.
  • When I create a key with access to one group only (and thus no access to my personal library and default group access to none), i get a no write access error: "the key you have logged in with does not have write access to your library [which is correct], nor to any groups" [not correct: I have given this key access to an individual group].
    When I create a key with access to everything, ie my personal library, all groups by default, and all groups individually, I can only select my library, no groups are listed even though i have granted access.
    When I create a key with access to groups only, both as the default for all groups and set per individual group, the app crashes (without the option to send a crash report; force stop is the only option i get, sorry).

    I'll just keep uploading to my library and move thing from there. Thanks for all your trouble!
  • I am having the same problem accessing group libraries. Any new suggestions?

    The workaround achieves what's needed, but it requires remembering exactly which entries need to be moved from the (huge) my library and into the group library—making it really inconvenient for managing larger groups of entries. This really detracts from the utility of this mobile app. It's great, and fixing the group library access is the only thing keeping me from rating it a 5.
  • Is there a way to add a tag to the scanned item? As far as I can tell, this is not possible, but correct me if I am wrong. Without this option, the app is useless for me, I would simply not be able to find the scanned items in my library without remembering what these items were.

    A suggestion: it would be enough to 'hard code' the app to tag all items with, for instance, 'scanned with Scanner for Zotero'. It would then be easy to create a smart search to collect all the scanned items, and then move them one by one to collections or tag more appropriately. Also, this would part solve the group libraries problems mentioned in the previous comments - copy them to groups manually, but at least knowing where to find the items.

    Otherwise, the app looks great and would be very useful.
  • edited January 27, 2013
    I just installed Scanner for Zotero on my SonyEricsson Xperia Arc running Android 4.0.4. It took a while to understand the Zotero key mechanism and how to set it up for Scanner for Zotero. Once I managed to get everything right, I brought out a few physics books from my library, scanned their ISBN numbers, and successfully uploaded to Zotero. They showed up as expected, but I noticed that none of them had the author names correct. All failed to separate the author names into first and second names as required by Zotero. Of course, I easily corrected this manually, but this is not a method I will be able to use once I have scanned the ISBN numbers of all 400+ physics books in my private library.

    Apart from this, Scanner for Zotero seems to work fine.
  • I installed th scanner on my xperia go, but sadly I cant get it to work on my xperia go. I have tried to get an api key online and entering it manually but I get the error message 'the key you have loged in with does not have write access to your laibrary...' I have given the key write access to everything from the zotero site via pc, but nothing helps. am I dooing somting wrong or is it a bug?
  • (make sure to also contact the developer directly - I believe he provides contact/support info n the app page and might not see everything that's posted here).
  • I did buy download the scanner for zotero from the market and paid the little donation. I am however unable to use it till date since I am having issues with the api key
  • same as above - contact the dev directly.
  • Issue resolved
Sign In or Register to comment.