Not signed in (Sign In)
 

Quick Links

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorrgoff
    • CommentTimeSep 9th 2011
     
    Hi, I'm trying to export a collection in my library by right clicking and selecting "export collection". When I do this it seems that everything goes okay, except that the progress bar goes far too fast (a very large collection, my whole library for a quick backup).
    This is the message that is then displayed:
    "An error has occured while trying to export the selected file"
    It then creates a folder with the respective name that has a .rdf file in it that is 1k in size.

    I've tried restarting my computer, because a Java update was installed and thought this may be the issue.

    I'm running windows 7 w/ SA 3.0b2.1 version. Other errors are listed below.

    Thanks!
    Ryan



    These are the errors I have reported, but do not seem to be directly linked to exporting:
    [JavaScript Error: "The file 'Atienza et al. - 2009 - Cryoablation time-dependent dose–response effect a.pdf' would exceed your Zotero File Storage quota" {file: "chrome://zotero/content/xpcom/sync.js" line: 666}]

    No chrome package registered for chrome://browser/skin/preferences/preferences.css

    [JavaScript Error: "Unexpected status code 500 in Zotero.Sync.Storage.Session.ZFS._getFileUploadParameters() (0_359QA4MI)" {file: "chrome://zotero/content/xpcom/storage/zfs.js" line: 580}]

    [JavaScript Error: "uncaught exception: A file sync error occurred. Please try syncing again.

    If you receive this message repeatedly, restart Firefox and/or your computer and try again. If you continue to receive the message, submit an error report and post the Report ID to a new thread in the Zotero Forums."]

    [JavaScript Error: "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsILocalFile.appendRelativePath]" {file: "chrome://zotero/content/xpcom/translation/translate_item.js" line: 649}]
    • CommentAuthoradamsmith
    • CommentTimeSep 9th 2011
     
    that last error looks like the culprit. One of the devs would have to say what it means, though.

    Regardless, though, exporting your collection/library is not a back-up. See here:
    http://www.zotero.org/support/zotero_data
    • CommentAuthorrgoff
    • CommentTimeSep 9th 2011
     
    Yes, I have heard that many times, but if all I want it to do is organize all of my PDFs, it is my understanding that the export function will work for this. I have tried migrating it the other way from computer to computer and it did not work well. Where do you locate your library in SA? I know it is not an exact backup, but no one explained to me what I am actually losing? (all I use it for is basically organizing PDFs and generating bibliographies).

    Running it now this is the only error:
    [JavaScript Error: "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsILocalFile.appendRelativePath]" {file: "chrome://zotero/content/xpcom/translation/translate_item.js" line: 649}]

    can anyone tell me how to fix this to export collections?

    Thanks!
    Ryan
    • CommentAuthoradamsmith
    • CommentTimeSep 9th 2011
     
    you can get to the zotero data folder form the advanced preferences in SA. You may have some minimal data loss with RDF export/import, you lose item IDs, which means if you work with the word processor plugin old documents won't work, if you do decide to use syncing it'll cause a big mess - there may be more, I don't know.
    It's also less convenient - you can just use any automatic back-up mechanism and point it to your data folder for back-up and will never have to remember and run through the export routine.
    • CommentAuthorrgoff
    • CommentTimeSep 9th 2011
     
    I guess the issue isn't backing up, but want the collection, with it's files on 2 computers without having to pay for online storage.

    If anyone can help with the export error I would greatly appreciate it!
    • CommentAuthoradamsmith
    • CommentTimeSep 9th 2011
     
    so you delete your entire library and re-import it every time you go from one computer to the other?

    As for your problem - try logging the debug of your export attempt
    http://www.zotero.org/support/debug_output
    You can try sending debug output - though it may be too large depending on the size of your library - and post the debug ID here. Alternatively, you may be able to look at it yourself and see which item triggers that error.
    • CommentAuthorrgoff
    • CommentTimeSep 13th 2011
     
    Thanks for the help, yes I have been deleting and re-importing when going from one computer to another.

    I ran the debug logger and it was unable to submit the report to a zotero server "Invalid response from server" was the prompt that came up.

    When I go to report errors, this is what shows up:
    No chrome package registered for chrome://browser/skin/preferences/preferences.css

    [JavaScript Error: "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsILocalFile.appendRelativePath]" {file: "chrome://zotero/content/xpcom/translation/translate_item.js" line: 649}]



    Should I post the entire debug log here??

    Thanks again!
    • CommentAuthoradamsmith
    • CommentTimeSep 13th 2011
     
    no, don't post the debug output here. Let's see if Dan has an idea on this. The error seems to indicate that there is a file-path that Zotero is struggling with - unfortunately that's not that uncommon as a Windows problem.

    I still don't understand why you're so averse to trying to move back and forth your Zotero data folder. That should work instantaneously and shouldn't have that type of problem.
    • CommentAuthorrgoff
    • CommentTimeSep 13th 2011
     
    I'll try it, it would avoid the problem I'm having with exporting at the least. I would still like to be able to export though for future use.

    Thanks for the help, I REALLY appreciate it!
    • CommentAuthorajlyon
    • CommentTimeSep 13th 2011
     
    There's an export bug in Standalone that Simon just fixed on the trunk: https://www.zotero.org/trac/changeset/10453

    Maybe he can comment here on whether this should fix your issue.
    • CommentAuthoradamsmith
    • CommentTimeSep 13th 2011
     
    ah yes, that looks promising.
    • CommentAuthorSimon
    • CommentTimeSep 13th 2011
     
    That should fix the issue in the next 3.0 beta, but as adamsmith notes, moving your data folder between machines is a better idea anyway.

Zotero Forums are powered by Vanilla 1.1.5a