not a valid CSL - file?

I've just started using zotero and i'd like to ad a citation-style:
"tah Geistes- u. Kulturwissenschaften"
but when i try to install it, this warning appears:
" scheint keine gültige CSL-Datei zu sein." what means, that the file is not a valid CSL file.
what can i do to use this citation style? im not a coder at all!
  • how exactly do you try to install this? I can't replicate the problem.
  • i went in zotero to "einstellungen" (preferences) there to "styles" then "weitere Stile hinzufügen" (add further styles) there i got to this site:
    and there i found the "tah-gkw.csl" and clicked "install" than a download started - after that i went again in the preferences and clicked the plus sign to add the "csl-file" from my download-folder.

    in the moment before the download began, i got the posted warning. and when i did the last step the warning "tah-gkw.csl" scheint keine gültige cls datei zu sein" (seems to be no valid csl-file"
  • I get the same error when I visit

    I just added "self" links to the style metadata, which were missing, but the problem remains. Maybe Zotero trips over the abundant comments in the XML?

    You can just download the CSL file and drag it onto a Firefox window, though. That installs it for me.
  • edited June 30, 2011
    drag the file onto a firefox window?? ok, i tried

    this happend: "file:///Users/friderikeschulze-grotkopp/Downloads/tah-gkw.csl scheint keine gültige CSL-Datei zu sein."
  • so where did you add "self" - i'm a noob! i don't know anything about html and co.
  • Rintze just updated that, so don't worry about it - I think I found the problem - I'll post back in 5mins with solution.
  • Did you download a fresh copy of the style before trying to drag it onto a Firefox window? I just updated the style online; you don't have to change anything in the style yourself.
  • edited June 30, 2011
    actually Rintze - that didn't work for me either - I just figured out that Zotero chokes when there's a comment preceeding the style element (Friderike - ignore the tech talk) - that's why the soz style works and the two others don't - I've just removed that comment from the two other styles, once the repository updates all three tah stlyes should work.

    Friderike - once a new time appears after the style (i.e. something later than 9.31) try again.
  • edited June 30, 2011
    Yeah, I figured that might be the problem. It's valid XML, though.

    edit: the style repository is currently updated every 30 minutes, and the fixed styles are available now.
  • edited June 30, 2011
    ok, so i'll try it later. thank you a lot!
  • Great: it's working!
Sign In or Register to comment.