Firefox cannot modify the needed file

I am unable to install Zotero on Firefox 5 because "Firefox cannot modify the needed file". What does this mean?
  • never seen that before. When exactly do you get that message and is that the full text?
    What operating system?
  • In the end, I had to individually erase the old Zotero files and then re-install. For some reason the old version of Zotero was not uninstalling properly?
  • I am having a similar problem installing Zotero on a Mac as a network user (with my home directory mounted from NFS). I can install is as a local user just fine, but in my network user account, I have two different things happen if I try repeatedly to install Zotero:

    1) Sometimes it downloads the plugin, says Firefox needs to restart, restarts fine, but Zotero is not installed (no error messages, so sign of it under Tools > Add-Ons, etc.)

    2) Other times, I get the same error message described above "Firefox cannot modify the needed file".

    Any ideas?
  • This sounds like a Firefox issue, not a Zotero one.
  • I'm having the basic issue that every time I attempt to install Zotero (whether I'm downloading Zotero from the site or the firefox plugins site), when I open the program in my Firefox browser (running Lion on a Mac), I get the error "Zoterno could notbe installed because Firefox cannot modify the needed file". Any idea if there is anything I can do about this?
  • Ask Mozilla doesn't work either, they say it's a Zotero problem - I'm giving up on it & going with Mendeley, too bad as it looks like the Zotero features are better.
  • where's the thread on that on the mozilla forum?
  • Have you tried creating a new Firefox profile?

    (Also, yes, cgacrew02, where is the thread where they told you that? None of the ones I see, including the two you started, have any responses.)
  • And, finally, if you're not set on FF you could use Zotero standalone and Chrome or Safari connector.
  • Thank you Adam, I've got the standalone installed but haven't figured out the handshake with my browser yet.

    Dan, I'll try the new profile option again today - I've deleted all Zotero files and right now only have the standalone installed.
  • I found a solution for this because I had the same problem. It is a work-around. I am using Firefox 8.0
    1. Use your IE browser and save the add-on to a location on your HDD.
    2. Go to where you saved the add-on and then right-click and will ask you for an application to open it...browse to where your FireFox.exe located and it should install successfully.
    3. Open your MS Word, click on the Add-In ribbon of MS Word 2007, and it will be there.

    Hope this helps!
  • Ibrad - are you running mac?
  • no he's not - there is no Mac Word 2007.
  • Thanks Adam - I know IE for Mac stopped being supported years ago, wasn't sure if I should try download the old version which is still available and try and force zotero in.
  • you could try the same thing with Safari instead of IE - I have no insight if this has much of a chance of working, but since it takes only a couple of minutes it may be worth a try.
  • >>>Ibrad - are you running mac?
    Adam is correct. I'm running W7. Interestingly enough, I had another issue with Zotero using Firefox 8.0 Browser and MS Word 2007 and them not communicating with each other due to Zone Alarm Firewall activated. I haven't yet narrowed down the exact setting. Too much homework to do to worry about it right now. I'll post in the right forum discussion when I figure it out.
    Cheers, Brad
  • Thanks Brad - Adam, I tried with Safari as well, no go.
Sign In or Register to comment.