New style created for Currents in Biblical Research

The journal Currents in Biblical Research ( requires a colon-separated author-date format: E.g., (Goodblatt 2006: 136-39), and a bibliography format that is similar to the American Anthropological Association stylesheet: E.g.,

Goodblatt, D.
2006 Elements of Ancient Jewish Nationalism (New York: Cambridge University Press).

I created a new (draft) style for Currents in Biblical Research, based on the Chicago (Author-Date) format. The style formats parenthetical references correctly and gets the basics of the bibliography format down, but still needs a bit more work. In the draft style the example above looks like this:

Goodblatt, David
2006 Elements of Ancient Jewish Nationalism. New York: Cambridge University Press.

(1) I haven't figured out how to make first names appear as initials; (2) I don't know how to place publication information for books in brackets; (3) I don't know how to indent 3rd and subsequent lines under the title, but this can easily be adjusted in a word processor.

The style is available here:

Feedback is welcome. If the style is worth uploading to the repository, feel free to do so. Thank you!
  • thanks.
    You can initialize authors' first names by including
    initialize-with=". " in the <name> node
    i.e. in your case:
    <macro name="contributors">
    <names variable="author">
    <name and="text" name-as-sort-order="first" sort-separator=", " delimiter=", " delimiter-precedes-last="always" initialize-with=". "/>

    Also, please include a <link> field in the info section of your style (the link is the same as the id) check any existing style for an example. I don't know why that's not in the instructions, I'll try to get to that asap.

    Finally, the category field "generic-base" should be reserved for generic styles - I think "theology" would work well here.
  • Thanks, Adam.

    I made the changes you recommended to my own copy. Unfortunately, including initialize-with did not have the desired effect of initializing the first name. It sounds like the same problem as the people in this thread are having:
  • edited May 1, 2011
    Good work. Remove the form="short" attribute from the name element, and it will provide the given name initials on all cites. (When form="short" is set, the initials are only included if they are needed to distinguish two or more authors with the same family name.)
  • edited May 1, 2011
    there is no form="short" on that name node - it's only in the contributors-short macro, where it presumably belongs.
    I'll have a look on Monday.
  • Ach, of course, this is about the bibliography, not citations. In the test pane, adding initialize-with=". " seems to work fine for the bibliography.

    @dmiller, if you paste the current version of the style into your link above, I can take a look as well, both at the initials thing and the other issues.
  • ah - I had overlooked the other issues - 2 shouldn't be a problem, but 3 might not be possible - I think I tried this and failed for AAA - but maybe Frank has better luck.
  • @fbennett, has been updated to the current version. Thanks for taking another look.
  • I get initialized authors with this. Did you try in the test pane?

    For the parentheses, just find
    <text macro="publisher"/>

    and turn it into:
    <text macro="publisher" prefix="(" suffix=")"/>

    If you need to get rid of the period before that, delete the period in the group prefix six lines above - you might have to double check if theses are still working correctly.
  • I've made a number of changes to align the formatting more closely with the CBR style sheet. The revised version is here:

    A few issues remain:

    (1) For the life of me I can't get initialized authors. I added initialize-with in several places and now get full initials for editors, but no dice on the primary author.

    (2) The style sheet requires punctuation outside quotation marks. I know 'punctuation-in-quote' ( is supposed to make this possible, but I don't know how or where to implement it.

    (3) The style sheet also requires single quotes instead of double quotes. Is there a way to make this change?

    (4) Series and # of volumes information should be in brackets with the publisher information, like so:

    Boyarin, Daniel
    2002 “The IOUDAIOI in John and the Prehistory of ‘Judaism’”, in J. C. Anderson, P. Sellew, and C. Setzer (ed.), Pauline Conversations in Context: Essays in Honour of Calvin J. Roetzel (JSNTSup 221; Sheffield: Sheffield Academic Press): 216-239.

    What I get with the latest cbr.csl is this:

    Boyarin, Daniel
    2002 “The IOUDAIOI in John and the Prehistory of ‘Judaism’”, in J. C. Anderson, P. Sellew, and C. Setzer (ed.), Pauline Conversations in Context: Essays in Honour of Calvin J. Roetzel JSNTSup 221 (Sheffield: Sheffield Academic Press): 216-239.

    (5) Is there a way to make (ed.) show as (eds.) when there are multiple editor?

    (6) Finally, since I don't like having URL's pasted into my bibliographies (and they are not required by the style sheet, at least for print publications), I removed the following:

    Thanks again, for working with me on this.
  • 1. Are you also seeing this in the test pane? As I say, initializing works for me with your style.

    2 and 3 put this right below the info section, i.e. below
    </info> (and don't worry, this took me a while to figure out, too):

    <locale xml:lang="en">
    <style-options punctuation-in-quote="false"/>
    <term name="open-quote">‘</term>
    <term name="close-quote">’</term>
    <term name="open-inner-quote">“</term>
    <term name="close-inner-quote">”</term>

    4. The volume number is currently included in the "locator" macro - remove the part referring to books etc. there and include it in the publisher macro.

    5. your form="short" instead of form="verb-short" on the label node: The former abbreviates "editors" the latter abbreviates "edited" and thus has no plural.

    6. Sounds good.
  • For the life of me I can't get initialized authors. I added initialize-with in several places and now get full initials for editors, but no dice on the primary author.
    This may be way off target, but just in case ... have you checked the Zotero items for the names that are not rendering correctly? They should be entered in two-field mode, with a one tiny square box in the icon to the right of the name (clicking on the icon switches modes ... ?).
  • edited May 3, 2011
    Re: 1. I've tried it in the test pane as well as in Word. @fbennett: Names are entered in two-field mode. No luck.
    Re: 2-3. That's the fix. Thank you!
    Re: 4. Works for volume number but not for series and series #. The series field in Zotero must be tagged as something other than series because it doesn't show up in the csl.
    Re: 5. Thanks!

    Latest version here:
  • 1. How do first names look for you in APA style? (APA initializes, too).

    4. series are referred to as "collections" in csl - i.e. "collection-title" and "collection-number". This page by fbennett is your friend:
  • An update on my continuing problem with initialization....

    APA initializes fine.

    I added "initialize-with" to every "name and=" line and I now get initialization in books listed by editor; the editors are also initialized properly within the citation in the case of essays in edited volumes. The first names of authors still do not initialize, however. The problem seems to be in this section of code or in the way the contributor macro is used later on in the citation style:

  • edited May 11, 2011
    1) You have to enclose your CSL code (or any HTML/XML tags you want to show in your post) in <code> and </code> tags.

    2) You seem to have stumbled on a bug. The culprit is the cs:substitute block in the contributors macro, which somehow messes with the name initialization (setting initialize-with on cs:name in the "editor" and "translator" macros doesn't solve the problems, so something murky is going on). Assuming you want substituted editors and translators to be rendered the same as authors, the easiest way to fix this is by changing:

    <text macro="editor"/>
    <text macro="translator"/>


    <names variable="editor"/>
    <names variable="translator"/>

    (if you take this route, you can delete the editor and translator macros)
  • Thank you! That fixes the abbreviation problem.

    In addition to the initialization change, I corrected series and volume number formatting to match the style sheet.

    The final (?) version is here
  • thanks, it's on the repository at
  • By the way, the Currents in Biblical Research style seems virtually identical to the style for the Journal for the Study of the New Testament (;subject=T20&amp;sortBy=defaultPubDate desc#tabview=manuscriptSubmission), which is also published by SAGE.

    Two more SAGE Biblical Studies / Theology journals are quite similar:
    Journal for the Study of the Pseudepigrapha (;subject=T20&amp;sortBy=defaultPubDate desc#tabview=manuscriptSubmission)
    Biblical Theology Bulletin (
  • dmiller - if you make sure if the styles are actually the same and if not what exactly the differences are we could make those styles and put them up, too.
  • For some reason the fix for single quotes stopped working. Instead of quotation marks Zotero now displays �. The question marks appear in chrome://zotero/content/tools/csledit.xul, but not when I open the csl in Notepad. I've tried uninstalling and reinstalling to no avail. Is this a bug similar to the one described here (
  • still works for me - are you using the style from the repository? Have you tried re-installing from the repository? Which Firefox locale are you using?
    I don't think it's the issue from the thread you link to - that was slightly different and has been fixed, anyway.
  • I tried re-installing from the repository and that fixed the problem. Not sure how the file got corrupted in the first place.

    Creating a style based on CBR for JSNT is on my to-do list...
  • I appear to be experiencing the year disambiguation error described in this thread:

    Articles published in the same year are labeled 1944a, 1944b, etc., by Zotero. Unfortunately, the result does not correspond to the exact sequence of publication. E.g., issue 35 (2) is listed as 1944b, issue 35 (1) is listed as 1944c.

    If you can point me to a fix for this, I will gladly make a change to the style.

Sign In or Register to comment.