Command: app(u')... error after inserting a citation

First the essentials: I am running Zotero 2.1.5 on Firefox 3.6.16 on my MacBook (Mac OS X 10.5.8). I have the Word plug-in 3.1.2 installed as well as the PythonExt I use Word 2004. I have not upgraded to Firefox 4 because the web-based version of Lotus Notes, through which I get my work email, is not compatible and we have been advised to wait.

I have been recently getting the following error AFTER inserting a citation: COMMAND: app(u'/applications/microsoft office 2004/microsoft word').active_document.fields[78].result_range.font_object.color_index.set(aem.AEEnum('\x01\xfd\x96\x7f')). This appears to be an error message no one else on the forum receives because I looked for advice on how to solve it and couldn't find the same one. In any case, the error doesn't seem to do any harm - it just appears after inserting the citation. However, if I could prevent it from popping up, that would be nice. Could you please advise? Thank you.
  • Upgrading to Firefox 4 is unlikely to change anything here, but this is certainly strange. Does this happen in a new document? Or only in an existing one? Have you changed the text color in any way?
  • I've been having the same problem for a few hours now.
    CommandError: Command failed:
    OSERROR: -1708
    MESSAGE: Application could not handle this command.
    COMMAND: app(u'/Microsoft Office 2004/Microsoft Word').active_document.fields[58].result_range.font_object.color_index.set(aem.AEEnum('\x01\xfd\x96\x7f'))
    Inserting a citation in a new document works fine. Put copy/pasting, deleting the bibliography or changing the citation style of the existing one doesn't help. And I haven't changed the text color or anything else.
  • If either of you can send a document that's producing this error to, we'll take a closer look.
  • Hi Simon,

    I tried inserting citations and biblio into a new document and that worked this error message did not appear. So it's only the document that I've been working on for a while (before and after upgrading to the new Zotero 2.1.5, I assume) that has the problem. I have emailed the doc to you to see if you can find the problem. No - I haven't changed text color, either.
  • hi sarah, hi simon,
    has one of you found a fix for this error yet?
  • I haven't heard back yet. As I said, new documents don't produce the error. It's just the one I'd been working on for a few weeks (during which we upgraded to Zotero 1.2.15 and 1.2.16, I think). Is it the same for you?
  • yes, it's the same problem, but I haven't even upgraded to 1.6., so that can''t be the cause. No idea. I'm still hoping for some help here.
  • This appears to have been caused by a bug in Word 2004. Under certain circumstances, which you appear to have encountered, Word 2004 apparently returns an incorrect value for the "color index" property of text range. You can try the MacWord Integration Trunk XPI, which contains a workaround, although if you do, you should make sure to install Zotero MacWord Integration 3.1.3 when it is released. Alternatively, you can try deleting your bibliography and adding it back when you are finished writing, or upgrading to Word 2008 or 2011, which don't appear to have this bug.
  • Thank you Simon!
  • Thank you, Simon!
Sign In or Register to comment.