Unwanted [Available at:] and [Accessed date] information in reference list

I just installed a new computer and am now using Windows 7, Firefox 4, Zotero 2.1.1, Word 2010 and the corresponding plug-in.

Zotero had been running nicely on my old computer, but in this new combination this problem arose:

For most of the styles I tried, including Cell J, EMBO J, Harvard reference format 1 (author date), they all generated the Available at, and Accessed date information in the end even for Journal Articles, which is of course unwanted. Even though for most Journal Articles the Available at filed is empty, they still managed to generate this information followed by a space. However Chicago manual of style (author-date) and Nature styles didn't show this problem.

How can I somehow fix this?

Thanks very much!
  • No solution, but I can confirm that this is an issue - it seems like the testing for the URL variable may have changed or something along those lines - we'll try to figure out what exactly is going on.
  • This looks like a failure of the implicit conditional logic associated with the group element. I'll work up some tests and see if I can replicate the fault.
  • I have been unable to reproduce this behavior, either in the processor test framework or in the word processor. The system is Linux Ubuntu 10.10 with Firefox 4, Zotero 2.1.2 candidate (multilingual), Open Office 3.3, and the 3.0a1 plugin. I tested with cell.csl and harvard1.csl. In the word processor, I tested with both books and journal articles, with and without the "Include URLs of paper articles" tick-box selected.
  • edited March 30, 2011
    From the test pane with the current Branch xpi 2.1.2r8816 using Harvard1
    (FF 3.6.16 Ubuntu 10.04)

    Author1, O., Author7, T. & Author3, T., 2008. Article No Issue No Pages Url Full Date Abstract. Test Journal, 12, pp.23-32. Available at: [Accessed December 16, 2008].

    <bib:Article rdf:about="#item_107">
    <dc:title>Test Journal</dc:title><prism:volume>12</prism:volume>
    <dc:title>Test Article</dc:title>
    <dcterms:dateSubmitted>2008-12-16 21:40:10</dcterms:dateSubmitted>
  • Is just get this from Open Office, which I guess is correct, if the URL tick-box is unchecked?Author1, O., Author7, T. &#38; Author3, T., 2008. Test Article.
    <i>Test Journal</i>, 12.
    (Newline inserted for readability)

    Looks like this may be system-dependent, and may not be a processor issue.
  • I just have the test panel - I don't have the Ooo plugin installed bc I'm still working on my dissertation with 2.0.9.
    Could this be different for some reason in ML and regular Zotero? Can someone else help test this? (System sounds unlikely - our's are pretty similar and very distinct from the OP).
  • If the issue is the suppression of the URL and access time, isn't that controlled by the integration layer, before shipping the data to the processor? (At least I don't remember implementing anything like this.) If that's the case, the unwanted output might occur only in the test panel.

    Or maybe I'm missing something about the issue.
  • I'd assume that Raya has been testing this in Word, though, as she mentions her word version and the plugin? I think we need some extra testers. help?
  • I have the same issue. I was running AMA style citations in my word doc and after upgrading to zotero 2.1.1 for windows and upgrading the plugin I noticed the extra "available at" in my bibliography. Mine go away with the NLM style, although in NLM there are [cited...] fields that I would like to get rid of.
  • I used word 2010 indeed.

    What's creepy: I went back to my old computer afterwards and re-inserted the bibliography to the same document. The [Accessed:] and other fields are there again! As I said, on my old computer things had worked out fine. There was no such problems before, and I didn't change any installation on my old computer (Windows Vista, Word 2007, Zotero and FireFox versions lower but don't remember which one -- they are not in my hand right now).

    The only thing I did was that I tried to sync my library with Zotero server...Well I'm not a computer guy, so this might sound stupid: can sync change the records somehow???
  • Right, about the include the URL box:

    If I check the box, the bibliography will look like this:

    Ahmad, K., and Henikoff, S. (2002). The histone variant H3.3 marks active chromatin by replication-independent nucleosome assembly. Mol Cell 9, 1191-1200. Available at: http://www.ncbi.nlm.nih.gov/pubmed/12086617 [Accessed February 14, 2011].

    If I uncheck the box, it looks like this:

    Ahmad, K., and Henikoff, S. (2002). The histone variant H3.3 marks active chromatin by replication-independent nucleosome assembly. Mol Cell 9, 1191-1200. Available at: [Accessed February 14, 2011].
  • Uhmz. I'll take a close look at the style later on, to see if chopping out the URL should also quash the Accessed note.
  • edited April 1, 2011
    Took that look, and there's nothing to fix in the processor for this one; it's a style issue.

    The style uses a nesting group to join the URL to the access date note:<group>
    <text value="Available at:" suffix=" "/>
    <text variable="URL"/>
    <group prefix=" [" suffix="]">
    <text term="accessed" text-case="capitalize-first" suffix=" "/>
    <date variable="accessed">
    <date-part name="month" suffix=" "/>
    <date-part name="day" suffix=", "/>
    <date-part name="year"/>
    According to the specification:
    Note that cs:group implicitly acts as a conditional: cs:group and its child elements are suppressed if a) at least one rendering element in cs:group calls a variable (either directly or via a macro), and b) all variables that are called are empty. This behavior exists to accommodate descriptive cs:text elements.
    (emphasis added)

    So if there is a date inside the child group, that triggers rendering of the entire macro. To produce the expected behavior, the outer group should be replaced with a <choose> wrapper.
  • thanks very much for taking a look at the issue, but how do I understand that in a layman's language? There's nothing I can do except manually delete the extra fields from the bibliography?
  • There are no laymen in the Zotero community; only users with varying degrees of expertise. :)

    The style needs to be fixed, which is relatively straightforward. You can either read the CSL 1.0 Primer and refer to the Specification in order to make the changes yourself. That has the advantage of putting you in control of your own desk (and gives the community another mentor, which is always a good thing).

    You can also wait for someone to act on this thread (which will probably happen fairly soon, since Cell and Harvard 1 are widely used -- it depends on how many other people complain).
  • I have the same issue (FF 3.6.16, Zotero 2.1.2, OO Add-on 3.5a1) and I doubt that this is caused by a style issue since switching style does not change anything but the style. The Acessed ... thingy is still there.
  • I, too, am having this problem and the last thing I want to do is manually delete the "available at" mess. Please fix this Zotero, I have 22 pages of references!!!!!
  • edited April 1, 2011
    This is definitely a style issue. The same code block has been borrowed across a number of styles, so you see the same behavior in many styles. It's a simple thing to fix, and tomorrow I'll post a revised Harvard 1 to illustrate how this can be fixed.

    Don't take this the wrong way, and I understand the pressures that everyone is working under, but please remember that this end of Zotero is driven by a community of people who have their own research to attend to. The CSL team (consisting entirely of full-time academics and grad students, at the time CSL 1.0 was in development) have put together very complete documentation on the CSL language, including a Primer that can be found on the CSL website. adamsmith, in particular, has invested a great deal of time and energy, in the midst of his own degree studies, in providing support and fielding requests for style changes. We believe in this thing, which is why we're here; but please remember that we do have lives, and that we've provided the documentation linked above in the faith that people will refer to it, study it, put it to use, and enhance Zotero further through the sum of their efforts.
  • The style am I using is J Neuroscience...
  • at this time it would be useful for people to just list the citation styles where this is an issue. I guess it will have to be fixed manually...
  • edited April 1, 2011
    I'm having the same problem with Harvard. Much obliged if you can fix it.
  • edited April 1, 2011
    Nevermind; I may be misunderstanding the issue (and don't want to read the whole thread). But typically this problem is actually with the translators, and not the styles.
  • edited April 1, 2011
    No. This is absolutely a problem with the style code. I lay out the CSL and the logic dictated by the specification above. Jump to the post.
  • edited April 2, 2011
    Things have settled down on processor issues, and I think I may be able to help with sorting this problem out.

    With a little fiddling about with grep and sed, I've come up with a list of 89 styles that seem likely to be caught out by the strictness of the new processor. As adamsmith says, fixing them by hand is probably necessary, but as the processor is the cause of the commotion, I'm happy to help out with the fixes. For a start, I've fixed harvard1.csl, and I'll post the code block in a subsequent post below as a sample.

    In the list below, I'll start in on the styles beginning with "a", and post a note before moving on to another set. Anyone with style checkin access at zotero.org, please feel free to join the party, but there are no obligations here.

    (Edit: On note on the process for this. In connection with the migration to CSL 1.0, there are now two repositories, one for CSL 0.8.1 styles [the current Zotero repository linked from the zotero.org], and one for CSL 1.0 styles [in the CSL github archive]. As users of Zotero 2.1 might install a style from other source at present, and as the fixed styles will work in either Zotero 2.0 or Zotero 2.1, we should make the changes in the Zotero repository in the first instance, and pull a converted style across to the github CSL 1.0 repository. That way, the changes will be reflected in both sets.)

    Anyway, here's the list of suspects:aag.csl
  • In harvard1.csl, the following change will quash the "Accessed" note when the URL is empty.

    Old version:<group>
    <text value="Available at:" suffix=" "/>
    <text variable="URL"/>
    <group prefix=" [" suffix="]">
    <text term="accessed" text-case="capitalize-first" suffix=" "/>
    <date variable="accessed">
    <date-part name="month" suffix=" "/>
    <date-part name="day" suffix=", "/>
    <date-part name="year"/>

    New (correct) version:<choose>
    <if variable="URL">
    <text value="Available at:" suffix=" "/>
    <text variable="URL"/>
    <group prefix=" [" suffix="]">
    <text term="accessed" text-case="capitalize-first" suffix=" "/>
    <date variable="accessed">
    <date-part name="month" suffix=" "/>
    <date-part name="day" suffix=", "/>
    <date-part name="year"/>

    The other styles listed above probably need a similar change.
  • thankfully I don't think any of these styles have been modified between the Zotero and the github repository, so let's deal with this on Zotero SVN exclusively and move them over.
    (sorry everyone else for the technical details here, but it makes sense to have this discussed as transparently as possible.
  • Yep. I've filed a note on the github tracker to let the team know what's coming down the pipeline.

    Done with the "a" group. I'll start in on the "b" group now.
  • That's the "b" list done now. Next up: "c" through "f".
  • "c" through "f" now done, on to the "g" list. This is getting faster as I dust of my sparse knowledge of Emacs configuration. I'll stop the chatter and just tear through the remainder. More news in a bit.
  • edited April 3, 2011
    Done. All of the suspect files turned up by my pattern-matching guesswork have been fixed and checked into Zotero SVN.

    adamsmith knows the workflow for style changes, and can give an idea of when the updated files are likely to become available in the Zotero style repository.
Sign In or Register to comment.