Choosing Preferences in 2.1b2 gives strange error

Am I the only one to experience this - or have I missed a thread on this? Since upgrading to 2.1b2 from 2.1b1 choose "Preferences" any more. I keep getting the following error message (in German):

XML-Verarbeitungsfehler: Nicht definierte Entität
Adresse: chrome://zotero/content/preferences/preferences.xul
Zeile Nr. 566, Spalte 2: <prefpane id="zotero-prefpane-cite"

I don't know XML well enough but I could imagine it to be some missing bracket or something like that.
Does anyone have the same problem?
  • Yes. I have been experiencing this since firefox 4beta6. Does not happen with firefox 4pre8, yet zotero does not work with this version neither.
  • edited November 11, 2010
    Shouldn't have anything to do with the Firefox version—just whether the Firefox build is English or not. We appear to have overlooked merging new strings to non-English locales in 2.1b2. We'll likely release a 2.1b3 soon to fix this, but in the meantime you can change your user interface language to en-US to work around it.
  • Thanks. Looking forward to 2.1b3.
  • Dan's link works:
    or which one are you referring to?
  • edited November 11, 2010
    Strange, your link works, Adamsmith, but Dan's seems to be written with 4 slashes http://// This works in Firefox (checked just now), but not in Opera which I was/am using.
  • Was missing a trailing quotation mark, and the forum software was rewriting with four slashes. Fixed now.
  • edited November 27, 2010
    Hi everyone, I solved the problem like this:
    There is prefpane.cite and some lines of code more missing in the german "preferences.dtd". (Maybe also in other languages, I don't know)
    I took it out of the english one and copied it into the german one.
    Before that the preferences window wouldn´t open.

    The preferences.dtd should be revised to add the following code:

    <!ENTITY zotero.preferences.prefpane.cite "Zitieren">
    <!ENTITY zotero.preferences.cite.styles "Stile">
    <!ENTITY zotero.preferences.cite.wordProcessors "Textverarbeitung">
    <!ENTITY zotero.preferences.cite.wordProcessors.noWordProcessorPluginsInstalled "Kein Textverarbeitungs Plug-in installiert.">
    <!ENTITY zotero.preferences.cite.wordProcessors.getPlugins "Textverarbeitung Plug-ins runterladen...">

    <!ENTITY zotero.preferences.cite.styles.styleManager "Stile Manager">
    <!ENTITY zotero.preferences.cite.styles.styleManager.title "Titel">
    <!ENTITY zotero.preferences.cite.styles.styleManager.updated "Updated">
    <!ENTITY zotero.preferences.cite.styles.styleManager.csl "CSL">

    If someone wants to add this manually I suggest to search for the "zotero.jar" because it's in some wicked profile folder. (at least in Win 7) To open it you could use WinRar.
    The "preferences.dtd" files are in the folder "locale".
    Win 7
    Firefox 3.6.12
    Zotero 2.1 beta 2
  • Thanks, now it just needs to be done for every localised version. (Or better wait for 2.1b3 hoping it includes the repair).
Sign In or Register to comment.