Not signed in (Sign In)
 

Quick Links

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthortimw
    • CommentTimeJul 17th 2010 edited
     
    Hello community,

    I am writing currently on my bachelor thesis and was modifying an exisiting style (Chicago Manual of Style (Note with Bibliography)). Basically I made some changes of the order of the bibliography, the design and the seperators. Also I put some comments with ## for myself to work me easier through the style. I was working in the Zotero Reference Test pane and everything worked out fine. Now when I copied the text into an .txt and put it as a .csl file onto firefox I am getting an error message.
    Firefox tells me that it is not a correct .csl file and shows this message:

    XML-Verarbeitungsfehler: nicht wohlgeformt (not well formed)
    Adresse: file:///C:/Users/Tim%20Weinert/Desktop/CSL%20Literatur/Eigene%20Version%2018.csl
    Zeile Nr. 3, Spalte 65:<style xmlns="http://purl.org/net/xbiblio/csl" class="note" xml:ang="en">

    My big problem is, that I did not even changed anything with this adress. Actually I tried to erase this line, than I am getting other error messages mostly about a letter being "wrong". The online validator does not even start to work throught my style. Can someone crosscheck and tell me where is the problem.

    The file is available at: http://www.test.timweinert.de/Eigene%20Version%2018.csl

    Thanks a lot
    • CommentAuthormark
    • CommentTimeJul 17th 2010 edited
     
    xml:ang should be xml:lang, for starters.
    • CommentAuthortimw
    • CommentTimeJul 17th 2010 edited
     
    I am not shure if I am the only one who sees the strange symbols with the FF inside the text. Where does this come from. Is it my german firefox?
    • CommentAuthoradamsmith
    • CommentTimeJul 17th 2010
     
    if I remember correctly that depends on encoding - it's not the German Firefox, though.
    • CommentAuthormark
    • CommentTimeJul 17th 2010
     
    Strange symbols where? In the CSL file?
  1.  
    There are Latin-1 (ISO-8859-1) characters in that CSL file. It needs to be converted to UTF-8 to be valid XML. That's also why you're seeing strange symbols in Firefox.
    • CommentAuthortimw
    • CommentTimeJul 19th 2010
     
    @Dan Stillman,

    that sounds like the solution. How can I convert it to valid XML. Is there a freeware tool for that, or do I just have to adjust the options of the notepad editor while I am saving?

    Thanks
    • CommentAuthortimw
    • CommentTimeJul 19th 2010
     
    @mark: No the CSL file itself looks fine. It also works fine in the Zotero test panel. But when I drop it on Firefox it creates the error message shown above.
    • CommentAuthormark
    • CommentTimeJul 21st 2010
     
    Open the file in Notepad. Follow these instructions.
    • CommentAuthortimw
    • CommentTimeAug 11th 2010
     
    Ok, I managed now to change the coding to UTF-8. Now Zotero also accepts to install the style by dropping it to firefox. Now I have the next problem, the style is accepted but it does not appear in the list of styles. Even restarting the Firefox does not help. Anyone knows this problem?
    • CommentAuthoradamsmith
    • CommentTimeAug 11th 2010
     
    I'm not sure but it might require a <link> line
    i.e. put
    <link>http://www.zotero.org/styles/HSBremen</link>
    under the id line.
    • CommentAuthortimw
    • CommentTimeAug 12th 2010
     
    Hello Adam,

    yes that was the solution. I went on to check and i put in the link lines of another Citation Style. The other fault, as I think, was that I left the ID free. Now it works fine.
    Thanks to all
    • CommentAuthoradamsmith
    • CommentTimeAug 12th 2010
     
    tim - put a fake link to your style (as per my example above) - not to some other style. It doesn't matter that it doesn't (yet) exist.

Zotero Forums are powered by Vanilla 1.1.5a