Issues With New Biblographic Styles

Our first new wave of bibliographic styles is now avaliable. Zotero now supports IEEE, Nature and the National Library of Medicine's bibliographic styles. If you find any issues with these styles please post them here.
  • Can you make these publicly available? I'm getting a bit frustrated about having to repeatedly ask for this. I have no clue what you guys are working on, and no way to access it (the styles are neither in my SVN, nor in your's as near as I can tell).
  • Hey Bruce, I'm one of the programmers working on Zotero, and this last batch of CSLs were mine. If there's a public archive somewhere you want me to add these to I'm more than happy to do so. Just let me know what you want us to do with them.
  • mikowitz: the goal is that any tool can grab a given style from the URI of a cs:link element. So ultimately that might mean URIs like "".

    If for some reason you don't want to do that now (since Zotero itself doesn't yet have support for loading styles from URIs), I could imagine other solutions.

    Just put them somewhere where they're easy to grab.

    BTW, I've started working on a tutorial (that I will soon convert to HTML, complete with syntax highlighting). If any of you working on styles have something to contribute to that, let me know.
  • See also:
    anyway, great to see the list is growing!
  • I just tried to produce bibliographies with all three new styles and recieved the error message "ALERT An error occurred generating your bibliography. Please try again." I produced bibliographies successfully with all of the other, older styles.

    I'm running Zotero version 1.0.0rc4.r1687.
  • It's nice to have the styles, but isn't it a bit premature to say that zotero supports them? From what I see zotero can not generate bibliography with the new styles. In addition the openoffice and possibly the word plugins don't work with the development version. Can't you guys wait with the announcements until there is a working release?
  • Can you make these publicly available? I'm getting a bit frustrated about having to repeatedly ask for this. I have no clue what you guys are working on, and no way to access it (the styles are neither in my SVN, nor in your's as near as I can tell).
    Bruce: Michael didn't know about your SVN, and he'll add these there once the bugs are worked out, but we've been committing styles and translators the same way for about a year now—they're all in the same place in our SVN (albeit as SQL statements with escaped quotes). Every single commit is visible in the Trac Timeline, and you're welcome to subscribe to the RSS feed. You can even subscribe to the commit log for just scrapers.sql (though hopefully that file won't be used for much longer).

    Anyhow, the easiest way to grab a raw style at the moment is to just pull up chrome://zotero/content/tools/csledit.xul and select it. This is obviously far from ideal, but we'll have a new system soon.

    As for these styles, it does look like they're throwing an error when trying to generate a bibliography, but I'll let Michael comment on that.
  • edited September 11, 2007
    OK Dan. but yeah, embedding the files in SQL statements is not ideal. There's no way for me to know they're there (aside from you telling me), and I can't load them directly. Think code like:

    csl ="";)

    I'm less concerned about them being in my SVN, BTW. Just want to be able to GET them easily.

    Also, I like the idea that the other poster suggested of a style roadmap on the wiki so that users know what's coming, and so that style developers can avoid duplication of effort. I'll be happy to contribute to it.

    To me, the current priorities are Bluebook, Harvard and Turabian.
  • Right now it appears that the new styles only throw an export error in the newest dev build, but work fine in RC3. We're looking into what's causing the problems in the most recent build, and hopefully we'll get it sorted out.
  • The Nature citation style doesn't seem to be working with Word (for me, at least). Footnotes are left blank. Though it will produce a bibliography, I am left with footnote numbers at the bottom of each page without citations next to them.
  • Labmonkey is right: footnotes numbers are displayed why they shouldn't (but the bibliography is correctly displayed if you ask for it using "insert bibliography" at the end of the word doc)

    But another trouble remains: I can start a new bib using nature format and this work well, but switching previous doc (MLA format for example) does not work. Even worse, start a new bib using Nature format, convert it to MLA or IEEE, convert it back to nature and you get the same bug!

    Reported using zotero 1.0.0rc3 with FF and MS Word 11.3 (061213) under mac os x 10.4.10
  • edited November 29, 2007
    I created a stand-alone bibliography today w/ NLM, and for web pages, the "accessed date" and the URL don't show up in the bibliography.

    Example: a page in APA style:
    NPR : 'My Lobotomy': Howard Dully's Journey. Retrieved November 19, 2007, from

    Now NLM:
    NPR : 'My Lobotomy': Howard Dully's Journey.

    According to RefWorks (using Ref Grab-It) it should be
    NPR : 'My Lobotomy': Howard Dully's Journey [Internet]. [11/29/2007] .
  • Admittedly, the Zotero CSL needs tweaking, but I wouldn't rely on RefWorks' output as a reliable indicator of the proper citation. According to NLM's style guide, the citation for the above item should look something like:

    NPR : 'My Lobotomy': Howard Dully's Journey [Internet]. Washington: National Public Radio; [cited 2007 Nov 29]. Available from
  • Goodness, I hadn't even noticed that RefWorks doesn't add the URL either. That's what I get for being lazy and trying to avoid typing.

    Anyway, the URL and the Accessed Date were both in the Zotero record. I realize that Zotero can't be held responsible for information, such as author, location, etc., that NPR (or any other page editor) doesn't put into the meta-tags (or however the information is harvested), but I did find it odd that the information that *is* in my Zotero library wasn't making it into the reference, when it should be.
  • You're absolutely right, and that's why our CSL needs to be adjusted to include that data in its output. And we'll take care of it as quickly as possible.
  • And that's why I like you better than RefWorks. :)
  • Taken care of in the dev styles.
Sign In or Register to comment.