importing a Citation (capital C) datafile

I have been using Citation (capital C - a name brand from for a long time and especially like its ability to create linked notecards, but I'm very intrigued by Zotero's added attractions -- especially its web-friendliness and superior search capabilities, a big weakness of Citation. So I have been trying to import a large Citation datafile (or even a small sample of records from it), but am having trouble. (Searching the Zotero discussions for advice turns up lots of comments about lower-case citations but not upper-case Citation.)

I exported my datafile using Citation's RIS format and saved it as an ASCII .txt file (also tried ANSI), but the individual records get combined into a single record when I import it into Zotero, I lose foreign characters (even after saving the txt file with UTF-8 encoding), and several auxiliary fields (year, short/subsequent cite, all keywords, access phrase) get dumped into Zotero's date field. In short, a real mess.

Any ideas? I'd really like to give Zotero a try but can't face life without my current datafile.
  • edited August 28, 2007
    Can you try to make the smallest RIS file that fails for both counts (e.g. one with only two records, but containing foreign characters that fail to import & preferably as few fields as possible that show these issues)?

    Then copy/paste it here (checking that the output is the same as you see in a UTF-8 capable text editor).
  • I have exported Citation files as Endnote (.enl) using Citation's format, that can be imported into Zotero.

    But be aware that records in Citation's" Book- Extended Form" lose their Book title on importing and need to have the form changed to "Book" before exporting.

    Journal formats seem OK but you may need to experiment a bit.
  • Thanks for the tips. What didn't work one way seems to have worked the other way.

    The good news: I made a little Citation data file, as suggested, of two records (one English, the other French), exported it as an Endnote file, converted it to UTF-8 encoding, and it worked, accents and all. Thanks! (Though too bad about the need to change book forms.)

    In case you (or others) are interested, I also tried exporting the little Citation datafile directly (as a ANSI txt file, converted to UTF-8 encoding), and now Zotero wouldn't take it at all (neither as ANSI or as UTF-8). I got an "Alert" that say "No translator could be found for the given file." Fyi, here's what the file looks like in Notepad:

    AU - Acollas
    AU - Lemaire
    CT - Banques nationales foncières par division départmental, conciliant les intérêts des propriétaires, des capitalistes, des départements de l'état
    CY - Paris
    PY - 1848
    %2 Banques nationales foncières
    %K FR; CO; BK; 19c;
    %F Acollas & Lemaire 1848

    TY - JOUR
    AU - Adams, Edward F.
    TI - The trust in politics
    J0 - Overland Monthly
    PY - 1899 August
    VL - 34
    IS - 200
    SP - 120-22
    %2 Trust in Politics
    %K US; trusts; politics; regulation; 19c; concentration;
    %F Adams 1899

    I'd be interested to know if you see any problems with that. In any case, thanks again to both of you.
  • What happens if you remove the tags with the %? Those seem wrong.
  • edited August 28, 2007
    Several problems with that format:

    'TY' is a required field that isn't present for your first record.

    All records must terminate with the 'ER -' tag. That they don't might be the reason it all got imported as one record.

    %2, %K, and %F aren't valid fields & aren't deliminated with a dash

    %2 looks like it might be the 'T2 -' tag
    Is %K keywords? If so, that is the 'KW -' tag.
    %F should be replaced with 'ID -', I think.
  • Yes, I wondered about the % characters and figured some kind of record delimiter was missing. Well, I think I'll just convert to Endnote format first, rather than trying to fix these problems with Citation's RIS format. I've 6,000+ records in my datafile and haven't even experimented yet with the "Notes" records. Thanks again for your help with this.
Sign In or Register to comment.