Sync Issue Request Help (iPad)

Recently stopped working with iPad. Any help appreciated. Tried restart, clearing trash. Should have file space as I just bought storage weeks before this issue popped up.

Debug Code: D2046626906
  • You'll need to say more about what the problem is.

    See Changes Not Syncing for debugging steps and the information we'd need to help further.
  • I seem to have found a workaround. I restored a deleted item from the folder in question then edited the items on the desktop app and this seemed to allow the iPad to recognize the items where it previously did not.

    I believe this resolved the issue, but if there is something else I should do to ensure continuity / proper synching I'm all ears.

    Is it a general rule of thumb that deleting anything is going to cause problems? Am I best off just not deleting items? Or once items are deleted am I best off deleting them permanently?

    .......

    I've followed steps 1-5 and they have not resolved my issue. I only have 1 account, and everything is set to sync.

    Since last night half the items that are in my desktop / the online repository are in my folder. I imagine that the problem may have been that I deleted an item from the folder in question. I have since restored that item and it hasn't solved the issue for the missing items (though it did restore the deleted item).

    The problem is that some of the items I added to the folder from which I deleted an item are not syncing to my iPad.

    Other changes to my items from the desktop are showing up in my iPad. Similarly, changes from my iPad are showing up in my desktop.

    I don't have an error message that pops up with the synching issue... it just seems like the Zotero library / folder in question works normally with the strange absence of half of the items I recently added to it in my desktop. All of the files from the desktop version also show online.
  • Is it a general rule of thumb that deleting anything is going to cause problems?
    No, of course not. And this almost certainly didn't have anything to do with deleting items.

    There may have been a bug that caused some data changes to be missed by the iOS app, though we're not aware of any such bugs currently. Depending on when you added these items originally, it's possible the bug was in an earlier version.

    Regardless, if some data didn't sync, any subsequent change to the item remotely (including moving an item to/from the trash) would be likely to trigger another sync of that item and cause the data to appear. So while this shouldn't happen, recovering from it is as simple as, say, assigning a temporary tag to the items and then removing it.

    If there is a bug here, though, the best chance for getting it fixed would be figuring out how to reproduce it reliably.
Sign In or Register to comment.