Add Item by Identifier (ISBN) broken

I'm using Zotero 2.0rc5. My add item by identifier ISBN function no longer seems to work. It did when I was using a previous version of Zotero. The error message that I get is: "Lookup Failed. Zotero could not find a record for the specified identifier. Please verify the identifier and try again." I've tried this with a variety of ISBNs and none of them work. The Identifier works with DOI.
  • I didn't know you could do that, that might save time...
  • Try this one
    it works for me.
    If it doesn't work - can you create an error report?
    If it does, but the others keep failing - please provide examples that aren't working.
  • Tried the ISBN 9780670030774 and got the same error message: "Lookup Failed. Zotero could not find a record for the specified identifier. Please verify the identifier and try again."

    How do I create an error report? The field is grayed out in my Action button. And I can't click on it when the "Lookup Failed" message window is still open.

    Thanks much for your help.
  • Just to provide more info:

    I restarted Firefox and tried the ISBN provided above.
    I clicked on the "Add Item by Identifier" and pasted the ISBN into the field. Lookup failed message appeared.
    Tried the same steps again, this time manually typing the ISBN. Again, the Lookup failed message appeared.

    Hope this helps. Thanks!
  • do you type just the number or
    ISBN 9780670030774

    If you actually type the letters ISBN this will fail in the way you experience.
    If that's not it - have you tried disabling all extensions. If report error is grayed out there's nothing to report.
  • um, i only type the numbers.

    How do I disable extensions?
  • In Firefox:
    Tools --> Add-Ons
    Select "disable" for all but Zotero and restart Firefox.

    Also, are you behind some type of firewall?
    Can you access
  • No firewall. I can access worldcat fine.

    After I disabled extensions and clicked "Restart Firefox," the following message popped up:

    "Zotero MacWord Integration Error

    "The Zotero MacWord Integration installation succeeded, but a necessary component does not appear to be loaded properly.

    "Zotero can attempt to correct this for you. A Firefox restart will be required. Continue? OK /Cancel"

    When I hit OK, my Firefox restarts; however, all the extensions remain enabled.

    I disabled again, this time hitting "Cancel." My Firefox restarts with all my extensions disabled. I tested the ISBN and it did not work.

    I then enabled my extensions again, and disabled extension again. The "MacWord Integration Error popped up again." I clicked OK. Firefox restarted without disabling extensions. I tried ISBN and again, it did not work.
  • Provide a Debug ID for the Add attempt.
  • Debug ID: D1707964482
  • Zotero is proxying through your proxy and failing due to cross-domain restrictions. We'll have to look into this, but deleting the entry for from the Proxies pane of the prefs (possibly within the pop-up settings dialog of a multi-site entry on the list) should fix it.
  • There were two different proxies listed, both through my university library. I deleted one of them: Multi-Site and the ISBN function now works! I'm not sure how this might affect my use of Zotero when accessing items through the library proxy, but I'll cross that bridge when I come to it.

    Thanks for your help, adamsmith and Dan Stillman! Much appreciated
  • I read and followed all of the above instructions, but my ISBN lookup is not working no matter what I try. And it used to work beautifully . . . now it won't even find isbn records that it found before.

    I even uninstalled and reinstalled Zotero. I keep getting "Zotero could not find a record for the specified identifier. Please verify the identifier and try again."

    My error report code is: 823410604

    Can you help?
  • seems broken - might just be a temporary down - try again tomorrow.
    If not maybe worldcat has changed some interface and the isbn translator needs to be updated.
    While we're at that - there is no way the ISBN query could go through LOC instead, is there? The LOC data is so much better...
  • Okay, I'll try tomorrow.

    Meanwhile, where do I find LOC information? I'm new at this. But I'm happy to use a workaround - particularly if it works better.

    Thanks very much.
  • that wasn't directed at you, but rather at developers - but obviously you can just use the guided search of the library of congress
    and search for ISBNs there
    That's of course nowhere near as smooth, but worldcat data is actually pretty bad. The worst part is that it always only imports the first author of a multi-author book.
    LOC data on the other hand is pretty much always flawless and complete.
  • I understand. Hopefully the interface works tomorrow.

    Thanks. And you're right - that would be cool if Zotero's lookup worked directly with the LOC.

    I love this add on, anyway.
  • I'm having similar problems to the ones mentioned above with "Add item by identifier". It was working fine with ISBNs and DOIs, but then I upgraded from FireFox 4 to Firefox 5 for Mac... and now it can't find anything. I tried a couple of the tricks mentioned above with no success. I did send the Debug Output for this error.

    Debug code: D630483079

  • I am having the same problem now. It seems to have started yesterday. I can get some low number ISBNs, but not the more modern ones. Any ideas?
  • I just ended up doing upgrades of Zotero and Firefox, and eventually the problem seemed to get better.
  • My ISBN lookup function is not working. No error messages appear; it just seems to keep searching without finding anything or resulting in an error. Here is a code that my Zotero error-reporting showed: 716685346
  • My ISBN lookup is also not working - searching forever. Error report: 1145715279.
  • Error ID 911648442: Add item by identifier not working. Does not work even with ISBN number entered earlier in my library. Does not work on OSX nor W-XP.
    Standalone v. 3.0b2.1 on Mac OSX 10.6.8 and Windows XP Pro v. 2002 SP3 in VirtualBox of same MacBook Pro.
    One thing I could think of is that JAVA was updated; by Apple on OSX one week ago (JVM is now v. 13.6.0); update on W-XP also one week ago, actual jre v. 1.6.0_29.
  • My ISBN lookup worked fine the other day and now it has stopped working. It just now spins.
  • I'm having the same problem I typed in the ISBN code (0802825079)
    It just keeps spinning and there's nothing you can do.
    Tryed it on Windows 7 and XP
    Have used standallone in the past but I've found that it isn't as good as Zotero for Firefox.
    I can access, would I be able to type the WorldCat link into the ISBN search box?
  • "I can access, would I be able to type the WorldCat link into the ISBN search box?"
    no. For the time being you'll have to go through the Worldcat (or any other library's) search interface and import the items from there.

    Also - as you can see from the sticky thread, devs are aware of this - no need for further reports. If you haven't posted in this thread and would like to be notified of developments, subscribe to the thread on the left.
  • This is now fixed. Your copy of Zotero should auto-update within 24 hours, or you can update manually by clicking Update Now in the General pane of the Zotero prefs.
  • Thanks to Dan Stillman. Though manual updating did not find a new version, my Zotero on Mac is workig again since a few minutes ago and so it does on Windows XP in the VirualBox.
  • Has this been fixed? I've just come across this problem - I enter the ISBN number, but nothing happens, and I've tried with multiple numbers. I'm using Zotero standalone 3.0b2.1 on a Windows XP machine. I've tried updating the translators.

    Reporting # 93574669
    Debug # D887723534

    Thank you.
This discussion has been closed.