Word plugin can't communicate with Zotero

I've sent in error report '1713666275'

When I click any button on the Zotero toolbar in Word, I get 'Word could not communicate with Zotero. Please check firefox is running and try again'.

Firefox is running. I have tried restarting both word and firefox.
The problem occurs with both new and existing docs

I am running :
Zotero 2.0rc5
Word plugin 3.0a
Firefox 3.5.6
XP (Version 5.1.2600 Service Pack 3 Build 2600) and
Word 2003 (11.0.8313)

I upgraded to 2.0rc5 a few days ago, and that seems fine.
I upgraded the word plugin this morning (first time since upgrading to Zotero 2.0), and it hasn't worked since.

Any help gratefully received!


  • could it be this?

    if not, try this (thought it's for a different error)
    make sure you have Open Office closed while doing that.
    And I know that is a stupid question but just trying to cover all bases - you have tried restarting your computer?
  • Thanks Adam - I never knew about Firefox profiles, so that was an interesting thing but not the problem I'm having, sadly. The other one doesn't seem to be it, and I have tried restarting.
  • The other one doesn't seem to be it
    But you've tried it? Reinstalling the plugin and/or Reinstall Word Components?
  • Sorry - I have now, closed word, uninstalled and reinstalled the plugin, restarted firefox, restarted word.

    I still get the error.
  • Just to make sure the plugin is installed correctly, close Word, go to C:\Documents and Settings\[username]\Application Data\Microsoft\Word\STARTUP and delete Zotero.dot. Then restart and make sure the Zotero toolbar is gone. Then go back to Firefox and do Reinstall Word Components, and then try again.
  • I've just done all that
    And I'm still getting the same message.
  • We're working on a fix for this, but we're not quite sure of the cause, and it definitely shouldn't happen in a standard configuration. Are you running any software in the background on your system? Virtual desktop software, utility programs, antivirus software, etc.?
  • I hope this doesn't confuse the discussion, but I'm having what seems to be the same issue.

    I noticed that some other people have had the issue in the forums here, but none of those discussions seem to help. I checked the plugin troubleshooting page too, and am not running Firefox in no-remote mode. Also, the "Report Errors" option in Zotero is grayed out. I'm using Word 2007 on a XP machine (Service Pack 3) with Zotero 2.0rc5 and WinWord Integration 3.0a3.

    I'm also running Avast! antivirus (version 4.8) and ZoneAlarm (version I tried disabling both Avast! and ZoneAlarm. Still no luck. I tried disabling all of my Firefox add-ons except for Zotero and the WinWord Integration and then reinstalled the WinWord plug-in. I then restarted both Firefox and Word, but still have the same problem.

    Any ideas/solutions would be greatly appreciated! (By me and my dissertation!)
  • Okay. This is wierd and possibly embarrassing.

    I went home last night, turned off the laptop
    This morning, I came in and saw your email.

    I went to check my Zonealarm version and noticed I needed an update to the signature file, so installed that.
    I went to check the Zotero addons and uninstalled all the ones I wasn't using. there were about 2-3 including google notebook and at least one other I can't remember.
    Then I thought, I'll just try again.

    And now it works.

    I promise I rebooted at least twice yesterday after installing, and am really sorry I didn't record the Zotero config before uninstalling those extra addons.

    By the way, I see amount is running Zonealarm

    My versions are:
    ZoneAlarm Security Suite version 9.1.008
    Truevector security engine version 9.1.008
    Driver version 9.1.008
    Antivirus/Antispyware engine version, Dat file version 1011435328
    Antispam version

    You might like to try getting yourself up to that version?

    Thank you very much for all your help - the support I've had here is far far better than I ever get from anything I actually pay for!
  • I think I spoke too soon.

    I worked happily for a couple of hours, turned off the laptop and went to lunch. I've just come back, and so has the problem. I'm trying to work out what's changed.
  • I've now upgraded to Firefox 3.5.7, and am working again.
  • And today its back again.

    Clearly an intermittent problem. Looking at the word macro, its clearly not finding the Firefox window, but I've no idea beyond that.

    Addons I am running:
    Delicious bookmarks 2.1.073
    Google toolbar 6.1.20091119W
    Jave quickstarter 1.0
    Scribefire 3.5

    I also have installed, but disabled (can't uninstall them):
    Google Gears
    ZoneAlarm Toolbar

    Other non standard (ie. don't come with XP) utilities include
    Jungledisk monitor 3.04
    RBTray 3.4

    Any thoughts?
  • I was still having the problem as well, until just a moment ago.

    I tried disabling all of my addons as well as my antivirus and firewall. None of that seemed to work.

    Then, acting on Cathryn's comment from a couple days ago, I installed Firefox 3.5.7 (a downgrade since I had been using Firefox 3.6). That seemed to do the trick!

    I re-enabled my addons, antivirus, and firewall and things still seem to be working.

    I'll report back if anything changes.
  • I'm having the problem of the Word plugin working sporadically. It hasn't been working for a while, but started working this morning. I downloaded some Windows updates and rebooted, and now it's not working again--I get the "Word cannot communicate with Zotero" message too.

    Admittedly, I have highly customized versions of Word and FF, but I didn't change either Word or Firefox before the reboot.

    I've got ZoneAlarm Internet Security Suite too.....hmmm.

    I've uninstalled and reinstalled the WinWord tools a bunch of times--no luck.

    ZoneAlarm Security Suite version 9.1.008
    Truevector security engine version 9.1.008
    Driver version 9.1.008
    Antivirus/Antispyware engine version, Dat file version 1011631008
    Antispam version

    Firefox 3.5.7
    Adobe DLM
    Advertising Cookie Opt out
    Delicious bookmarks
    eBay sidebar
    Java Quick Starter
    Live Click
    Microsoft .NET
    Move Media Player
    Read it Later
    Word Count Plus
    Zoho Notebook Helper
    Zotero WinWord Integration

    Word 2007 with Editorium macros (http://www.editorium.com/) and Adobe Acrobat 7.0 tools installed.

    Just adding my 2 cents in case it's helpful....
  • I've been having sporadic issues with Zotero for some while -- that is, it has only worked sporadically for some while. And now I'm nearing my dissertation and _must have_ a reliable biblio tool, so I'm almost on the point of calling it a day with Zotero -- except, I really liked it when it used to work, and I have a lot invested. I've tried numerous times either to get the issue addressed through the forums or find a solution. No luck. Try one more time...

    So: I'm presently running Windows 7 Ultimate 6.1, FireFox 3.6 with Zotero 2.0rc5, Oxygen OpenOffice 3.1.1 and the 3.0a6 plug-in. I have ZoneAlarm 9.1, NoScript 1.9947. This problem has persisted for months now, through upgrades from Vista to 7, from OpenOffice 2 to 3, Firefox 3 though 3.5. to 6. I've tried turning off ZoneAlarm and NoScript; have disabled all known troublesome extensions (e.g. Splitter) and selectively turned off and on other extensions in batches. I've upgraded and reinstalled and tested Java -- presently V6 U18. Zotero.org, zotero: and zotero://attachment, and chrome: are all whitelisted in NoScript. Nothing has made a difference I can see. There's a debug printout at D401949417.

    Any ideas?
  • Just to clarify: the error message is: "OpenOffice could not communicate with Zotero. Please check Firefox is running and try again'.
  • edited February 15, 2010
    it seems at least noteworthy that all three people in this thread with this odd and irregular error - that has really not been a frequent Zotero issue - have Zone Alarm installed.
    Could Zone alarm somehow mess with Zotero even when it's disabled?

    edit: make the four out of four with Zone Alarm - all of whom said they disabled Zone Alarm, without effect.
  • Just to continue with the comment above -- as I understand that Zotero needs some sort of quasi-server access to localhost, I've made sure that all the java executables have full access to ZoneAlarm's "Trusted Zone", and also listed in NoScript's whitelist. And no, FireFox is not starting with the "No remote" switch, and all Windows "Remote"-related services are available.
  • Responding to adamsmith's last comment: I noticed the consistent presence of Zone Alarm too. Disabling it didn't work for me, so I tried uninstalling it. After a system restart, Zotero seems to be working again!

    I guess I'm in the market for a new (free) firewall. Anyone have any recommendations?
  • as I understand that Zotero needs some sort of quasi-server access to localhost
    This isn't actually the case anymore—it was true for 1.0 but not for 2.0. But maybe ZoneAlarm has some non-network-based protections that are interfering...
  • I have a new laptop, and I've just been setting it up. I've installed OpenOffice, in an attempt to get around this. And I still get errors communicating with Zotero. I haven't installed Zonealarm.

    Given that a number of people are seeing similar problems, the word processor integration plugin is clearly not stable, so I'm deinstalling it and getting on with my essay. Zotero is still very useful, but more copying and pasting than I'd hoped.
  • I'll throw mine in here too.

    Windows XP
    Open Office 3.1.1
    Zotero 2.0
    O/O Integration 3.0a6

    When attempting to add a citation using the Zotero toolbar within O/O Writer I receive the following error message:
    “OpenOffice could not communicate with Zotero. Please ensure Firefox is open and try again.” I also get a similar message when attempting to use MS Word 2003.

    For OpenOffice,
    based on info from forums, I used the following command line:

    "C:\Program Files\Mozilla Firefox\firefox.exe" -silent -ZoteroIntegrationAgent OpenOffice -ZoteroIntegrationCommand addCitation

    If Firefox is closed and I use the command line above, then I get the following error message:
    “Firefox could not load the component required to communicate with your word processor. Please ensure that the appropriate Firefox extension is installed, then try again”

    If I open Firefox first, and then use the command line, I am allowed to insert the citation; but still cannot use the toolbar.

    For MS Word:
    again, used the following command line:

    “C:\Program Files\Mozilla Firefox\firefox.exe” -silent -ZoteroIntegrationAgent WinWord -ZoteroIntegrationCommand addCitation

    Using the command line, I can add a citation with Firefox closed and open; but it will not work using Zotero toolbar in Word

    yes, I am using ZoneAlarm and maybe that is part of the problem; but I wonder what is going on that causes it to work when entering the command line, but not using the toolbar. And, at one point a few weeks ago, it started working and then stopped again.
  • Since I seem to be able to get the O/O integration to work using the command line (via the Start/Run sequence on my XP computer, would it be possible to get the other "command lines" to do things like add bibliography, edit bibliography, etc. I looked a little bit in other places but could not find them
    What I mean is, I can use:
    C:\Program Files\Mozilla Firefox\firefox.exe" -silent -ZoteroIntegrationAgent OpenOffice -ZoteroIntegrationCommand addCitation

    to add a citation; I imagine that by simply changing the "addCitation" I should be able to do other things; where would I find those commands?
  • I seem to have the same problem:

    Yesterday I upgraded to the newest version of Firefox. Since then Zotero is giving me an error message when I try to insert a bibliography:

    "You must insert a citation before performing this operation."

    or when I try to insert a citation:
    "Word plugin can't communicate with Zotero."

    The document is filled with citations. Firefox is running and the citations are still in my library. I did update my Word plug-in. Anything else I am missing here?

    I use the following versions:
    Zotero 2.0
    Zotero WinWord Integration 3.0a3
    (NO Zone alarm)
    Firefox 3.6
  • I was reading about other people's problems with Zotero and Zonealarm Security Suite and thought back to when I first started having problems with it last year. Last Oct or so, I renewed my Zonealarm suite subscription and got a ForceField toolbar with it. I was using it in IE8 and had it disabled in FF. However, I got fed up with not being able to use Zotero properly and uninstalled the ForceField toolbar in the Windows Control Panel under Add/Remove Programs. Voila! The Word plugin has been working without a hitch for the last 5 days (no "Word cannot communicate with Firefox" message").

    Okay, maybe I could have tweaked the ForceField toolbar settings without uninstalling it, but I really wanted Zotero to work. :-) Now that I was hasty and got rid of the software, I found that I may have been able to fix the problem by clearing the ForceField virtual cache (see http://kb.mozillazine.org/Firefox_crashes#ZoneAlarm_ForceField , http://support.mozilla.com/en-US/forum/1/380950 , http://groups.google.com/group/mozilla.support.firefox/browse_thread/thread/eab83e3ead6e8a7d/a3ea1f679017ba29). Or maybe I really did need to uninstall the ForceField toolbar to make the Zotero plugin work. . . .

    Anyway, since most of us on this thread are using some kind of Zonealarm product, I hope this is helpful!
  • thank you so much!! i had the same problem - uninstalling zonealarm toolbar / forcefield did it!
  • My observation too -- uninstalled Zonealarm toolbar (even though previously disabled in FF3.6), Zotero now working reliably for first time in quite a while.
  • Just remember that the Zonealarm toolbar cannot be uninstalled through Firefox. You need to use the Windows uninstall.

    XP Professional SP3
    Firefox 3.6.3
    Zotero 2.0.2
  • okay just wanted to say thanks to this thread. i encountered the same problem - Word not being able to communicate with Firefox - and it seems the problem was solved by uninstalling the zonealarm toolbar. i have a zonealarm pro working, Word 2010, Zotero 2.0.2, Firefox 3.6.3 and XP Home SP3.
  • edited September 21, 2010
    I have the same problem: 'word cannot communicate with zotero'

    I tried to downgrade my firefox version to 3.5.7 as it seemed to work for someone but didn't work. I have no ZoneAlarm. I have a Mac, running MacOS 10.5.8, Office 2008 for Mac, Zotero 2.0.2.

    Any ideas?

This discussion has been closed.