iPadOS 17.2, Zotero Beta 1.0.25: Crash when searching in PDF (cmd+f)

edited December 6, 2023
I opened a PDF, pressed cmd+f and the app crashed. Tested it again with a different PDF, and it happened again.

Report ID: 287174222
  • I turned on debug logging and tested it again with the same result.
    Debug ID: D850577068
  • Hey @FeralFlora, I tried to reproduce the issue, but it didn't occur in my case.
    Can you please provide a video recording of when this happens? It might help understand the specific circumstances.
  • Hi @mvasilak,
    I will post a screen recording tomorrow.
  • Hi again @mvasilak,
    I finally got around to making a screen recording, sorry for the delay.

    I wasn't sure where to upload it, so I just uploaded to imgur:

    This time, it didn't happen consistently. I pressed cmd+f, then mouse-clicked back into the document to leave the search modal several times and got various behaviors:
    1. Search modal opens as expected so I can search the PDF
    2. The PDF closes and library search modal opens
    3. Zotero crashes (as seen in the video).

    In the video, I opened Zotero, opened a PDF, pressed cmd+f and then the crash occured.
    Here's the report ID for the crash in the video: 1156484396
  • @FeralFlora we have a fix, it'll be included in the next release. Thanks for bringing this to our attention, and please do provide any further feedback if necessary.
  • @mvasilak Great! I will report back as necessary.
Sign In or Register to comment.