Problem with Zotero update for mac (Error: no such column)

Hi all,
I've just updated Zotero on my macbook after a period of inactivity, and first had no library. I looked through the forums and opened my zotero.sqlite file with the zotero app, hoping that would solve the issue. Now Zotero won't open and I got this error message. Does anyone know what this means? Thanks so much!

Error: Error(s) encountered during statement execution: no such column: IA.authorName [QUERY: SELECT itemID, IA.parentItemID, IA.type, IA.authorName, IA.text, IA.comment, IA.color, IA.sortIndex, IA.isExternal FROM items JOIN itemAnnotations IA USING (itemID) WHERE libraryID=? AND itemID IN (16, 21, 29, 38, 43, 45, 56, 64, 84, 88, 92, 93, 97, 99, 109, 111, 114, 116, 113, 126, 129, 130, 131, 132)] [PARAMS: 1] [ERROR: no such column: IA.authorName]
Zotero.DBConnection.prototype.queryAsync@chrome://zotero/content/xpcom/db.js:680:13
From previous event:
Zotero.Schema</this.migrateExtraFields@chrome://zotero/content/xpcom/schema.js:691:11
  • This would've been caused by a database upgrade made by a version of the Zotero beta from over a year ago.

    You should be able to fix it by going to Tools → Developer → Run JavaScript and running the following command, and then restarting Zotero:

    await Zotero.DB.queryAsync("UPDATE version SET version=119 WHERE schema='userdata' AND version=120")
  • Thanks so much for your response! Where can I input that command?

    Unfortunately I can't properly open Zotero at the moment – the error message comes up. When I open Zotero preferences, I don't have a tools bar anywhere.
  • Tools is a menu.
  • Unfortunately I get the error message as Zotero is opening, so I can't access any of the menus beyond the "Zotero" menu. I've tried going into ->Zotero ->Settings but there's no tools menu there either.
  • Try pressing Cmd-` to cycle through windows. It should let you focus the main window, which will give you the full menus, including the Tools menu.
  • I don't have multiple menus, just the Zotero menu. The other menus show up very briefly while Zotero is opening, but disappear too quickly to be able to click on anything, and I'm left with just the Zotero menu. Cmd- does not have any effect, unfortunately.
  • edited 6 days ago
    It's Cmd-tilde — the key above Tab. It lets you switch between windows of the app so that you can focus the main window, which has the full set of menus. The popup window with the error will only have the Zotero menu.
  • Oops, that makes so much sense, sorry for the confusion. This worked and now I'm back into my collection. Thanks so much!!!
Sign In or Register to comment.