Problem Moodle Error/ Export PDF


i work at a university library and also offer help and support with Zotero questions as part of our Helpdesk Reference Management.

Now I received a request from a student who works with an mac, where I can't find a solution. The problem is the following: When the student opens documents from Moodle (our learning platform) e.g. lecture notes and then clicks on the Zotero icon in the browser in the PDF preview to export the document to the Zotero library, the following error is displayed: "An error occured while saving this item. Try again, and if the issue persists see Getting Help for more information."

With Pdf documents from other websites, the Safari Connector works great. Only documents that were previously opened in Moodle are not exported and display this error message.

Unfortunately, the student also received an error message when trying to retrieve the debug ID via the Safari Connector: "An error occurred while submitting the report. Undefined is not an object (evaluating 'Zotero.Date.dateTOSQL').

Currently I have advised him to drag and drop the PDFs into the library, this works without any problems.

I would just be interested to know why the error occurs. I am looking forward to a reply and thank you in advance.
  • Are they actually getting a PDF icon in the Connector's save button? What does it say if they hover over the save button? If they right-click on it and look in the Save to Zotero menu, is there a PDF option?

    Most likely Moodle uses some sort of web-based PDF reader rather than just serving the PDF file directly, which would allow the browser's PDF reader to display it and Zotero to save it. If there's a button or some other way to view the PDF directly (without actually forcing a download), that should work. Otherwise, downloading and adding to Zotero would be the way to go.

    (The problem with bug reporting is a known issue in the current version of the Safari Connector. It's been fixed in the other browsers, which get faster updates because they don't have to be distributed via the Zotero app.)
  • Thank you very much for your answer!

    The student answered me the following when I asked: "When I hover over the connector it says "Save to Zotero (PDF)". When I right-click on the PDF, in the browser's PDF preview, no Zotero menu item appears. However, with Wikipedia entries, I see multiple choices from Zotero."

    The student also notes the following: For PDF files that we have licensed as a university and he has activated the connection to the university network via VPN, the Zotero Connector works without problems. However, as soon as he disconnects from the university network, he gets an error message here as well. For freely available media, the connector works. Are there such technical restrictions when using the Zotero Connecor or is this assumption simply not possible?

    I told him the alternative of changing the connector.

  • Ah, OK, so PDF downloads happen via the Zotero app, not the Connector, and if these PDF URLs are behind some kind of web-based authentication, the Zotero app might not be able to download them (but it would work via a VPN, since then it’s just IP-based authentication). The Connector sends most info necessary for the app to access gated files (which is why Zotero can usually download proxied files), but Moodle might be doing something unusual.

    Can they provide a Debug ID from Zotero for a save attempt that fails?
  • Thank you very much for the feedback.

    That licensed PDF files cannot be saved via Zotero without access permission makes sense. This works via VPN authorization as a university member.

    Unfortunately, it is still not possible for the student to retrieve a debug ID. An error message is always displayed when trying.

    Currently, he can manage his literature with Zotero. PDF files can also be added to the library by drag & drop. We understand that further troubleshooting is not possible without a debug ID.
  • Unfortunately, it is still not possible for the student to retrieve a debug ID. An error message is always displayed when trying.
    I asked for a Debug ID from Zotero, not the Zotero Connector. File downloads happen via the app.
  • Yes, I understood that. I asked him about the debug ID via Zotero not via the connector but he replied that there is an error message also via Zotero.

    I shared the URL to this forum post with him. He said he is reading along.
  • edited January 27, 2023
    We would need the exact error message.
Sign In or Register to comment.